After K&N Hi-flow air filter install, stall at idle - Drive Accord Honda Forums
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
post #1 of 8 Old 11-19-2009, 07:55 AM Thread Starter
Vic
1st Gear
 
Join Date: Nov 2009
Location: Alpharetta GA
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to Vic
After K&N Hi-flow air filter install, stall at idle

Yesterday I banged up my hands pretty well installing a new K&N Hi Flow Air Filter and a standard cabin air filter. I was surprised to find that none of these procedures were in the owner's manual at all.

I managed to figure it out and get the new filter on. I'm noticing more power like I expected, but I'm also noticing that the engine now chugs occasionally at idle or when the auto-transmission shifts into a higher gear.

This morning my car acutally stalled on me after giving it some gas when a light turned from red to green.

Is there anything I could have messed up or not done properly on this?

-Vic
Vic is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 11-19-2009, 08:04 AM
4th Gear
 
inspire08's Avatar
 
Join Date: Aug 2009
Location: LV, Nevada
Posts: 436
Thanks: 0
Thanked 1 Time in 1 Post
Check your sensor, hose, and other tube related by the airbox to where you have insatalled the KN filter. Loose maybe or disconnected. Do you have any error code or check engine light?

2009 DIAMOND PEARL WHITE V6 EXL-3.5VCM

LS430/TSX LENS RETROFITTED HEADLIGHT
3M CLEAR BRA/3M TINT
1st-09 TSX SPLASHGUARD
09 TSX SWITHBLADE 2sets
09 TSX RSB 17mm
OEM SUNROOF DEFLECTOR
OEM BODY SIDE MOLDING
LED LIGHTS INTERIOR/EXTERIOR

INSPIRE TRUNK GARNISH CONVERSION
INSPIRE REAR SPOILER
CROSSTOUR LEATHER SHIFT KNOB
OEM COUPE WHEELS 18X8
inspire08 is offline  
post #3 of 8 Old 11-19-2009, 10:36 AM Thread Starter
Vic
1st Gear
 
Join Date: Nov 2009
Location: Alpharetta GA
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to Vic
no check engine light

I have a amaintenance light and B 12, but that was there before I installed and I've not yet cleared it out.
Vic is offline  
post #4 of 8 Old 11-19-2009, 12:37 PM
Administrator
 
andysinnh's Avatar
 
Join Date: May 2005
Location: Merrimack, NH
Posts: 2,386
Thanks: 4
Thanked 24 Times in 20 Posts
Send a message via AIM to andysinnh
It's real easy to dislodge a connnector or hose when you replace the air filter on these cars. And I"m guessing that you put a drop-in K&N filter and not a more major upgrade, right? So even though you're not throwing any codes - check to make sure everything is snug and tight - and make sure you look under the intake hose from the filter - there are some things on the side and underneath. Most folks who've changed the filter on these cars have had choice things to say about the experience....

A 3 "Honda" (and 1 "Ford" and 1 "BMW") Family in NH

12 Acura TL SH-AWD Tech Package (White, Wife's toy) 22k miles
15 Acura RDX AWD Tech (Kona Coffee, mine) new
14 Honda Accord LX Sedan (Black, Son#1's) 15k miles
04 Mazda Tribute LX 4WD (Black, Son #2's) 114k miles
08 Mini Cooper Hatch (White, Son #3's) 122k miles
andysinnh is offline  
post #5 of 8 Old 11-20-2009, 05:21 AM Thread Starter
Vic
1st Gear
 
Join Date: Nov 2009
Location: Alpharetta GA
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to Vic
got it

Last night, driving home, I noticed I did have the check engine light on. Stopped for a fill up and examined the hoses again. Sure eneough there was a smaller hose coming off the main one out the back which had come off. Put it back on and have no stalls or chugging.

I'm grateful the filter I put in will last a long time as this is not a task I'd want to repeat very often!
Vic is offline  
post #6 of 8 Old 11-20-2009, 05:27 AM
moooo
 
Join Date: Apr 2009
Posts: 1,147
Thanks: 0
Thanked 7 Times in 2 Posts
boy do i feel your pain vic, was changing the filter in my mini, just a simple drop in k&n, and all the clips that hold the airbox on just fell apart can you say cheap crap, needless to say a new airbox for a mini is 180 a new k/n cai was only 175. I cursed out the mini dealer then ordered the k&n cai. what should i expect anyways a screw for this car cost 10 bucks.
aeoporta is offline  
post #7 of 8 Old 11-20-2009, 06:16 AM
Administrator
 
andysinnh's Avatar
 
Join Date: May 2005
Location: Merrimack, NH
Posts: 2,386
Thanks: 4
Thanked 24 Times in 20 Posts
Send a message via AIM to andysinnh
Quote:
Originally Posted by Vic View Post
Last night, driving home, I noticed I did have the check engine light on. Stopped for a fill up and examined the hoses again. Sure eneough there was a smaller hose coming off the main one out the back which had come off. Put it back on and have no stalls or chugging.

I'm grateful the filter I put in will last a long time as this is not a task I'd want to repeat very often!
Glad to hear that you got it fixed - been there, done that in replacing the filter.

Now, just because you have a K&N in there doesn't mean you can ignore it. You need to take it out and clean and reoil it in a similar frequency to when you'd replace a normal air filter. The advantage of the K&N is that you can reuse it for the life of the car - but it still needs to be removed, cleaned and reoiled with the kit you can get from K&N. So, unfortunately, you will have to go thru this process again. But the suggestion others have when replacing the filter is to remove the air intake hose from the intake box - there should be a clamp around it - and this way you can just remove the lid to the airbox and not risk dislodging of hoses, etc. It's a bit of work to get that intake hose off, but in the end, it's less disruptive.

andy

A 3 "Honda" (and 1 "Ford" and 1 "BMW") Family in NH

12 Acura TL SH-AWD Tech Package (White, Wife's toy) 22k miles
15 Acura RDX AWD Tech (Kona Coffee, mine) new
14 Honda Accord LX Sedan (Black, Son#1's) 15k miles
04 Mazda Tribute LX 4WD (Black, Son #2's) 114k miles
08 Mini Cooper Hatch (White, Son #3's) 122k miles
andysinnh is offline  
post #8 of 8 Old 11-20-2009, 10:42 AM Thread Starter
Vic
1st Gear
 
Join Date: Nov 2009
Location: Alpharetta GA
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to Vic
True enough,

Thanks!
Vic is offline  
Sponsored Links
Advertisement
 
Reply

Tags
accord 06 intake diy, k&n hi-flow air filter

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Drive Accord Honda Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
The answer to the random question may be found under the Off Topic section of the forums and in the "Drive Accord Forums" category.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome