P0171 code - Drive Accord Honda Forums
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
post #1 of 12 Old 03-22-2010, 05:07 AM Thread Starter
1st Gear
 
Join Date: Nov 2005
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
P0171 code

Hi

I have 1999 Honda accord lx 2.3 . I just got a p0171 (fuel system lean ) code. I changed PCV valve cleared code and it can back 3 days later. I read it might be a fuel pressure regulator. Is there anyway to check to make sure what it is .


Thank You
mickey1987 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 03-22-2010, 05:10 AM
6th Gear
 
ry05coupe's Avatar
 
Join Date: Feb 2009
Location: Lexington, KY
Posts: 1,417
Thanks: 0
Thanked 2 Times in 2 Posts
I had the same code after installing a cold air intake. For me it just took cleaning the MAF and resetting the ECU by leaving the battery disconnected for 10 minutes or so. It hasnt been back since.

Latest mod: 35W 3000K Fogs.


2005 Accord Coupe i4
ry05coupe is offline  
post #3 of 12 Old 03-22-2010, 06:10 AM Thread Starter
1st Gear
 
Join Date: Nov 2005
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by ry05coupe View Post
I had the same code after installing a cold air intake. For me it just took cleaning the MAF and resetting the ECU by leaving the battery disconnected for 10 minutes or so. It hasnt been back since.
Do you mean " MAP sensor" I cant find a MAF sensor on a 1999 accord 2.3
mickey1987 is offline  
post #4 of 12 Old 03-22-2010, 07:41 AM
Moderator
 
SatinSilver's Avatar
 
Join Date: Mar 2007
Location: Ohio
Posts: 6,286
Thanks: 38
Thanked 104 Times in 64 Posts
I forget the code but it translated to "fuel system lean" and it was the fuel pressure regulator on a 99 lx I4. There was a tsb for this but warranty didn't cover it since I was WAY over on the warranty. I know it doesn't answer your question completely but wanted to pass along the info.
SatinSilver is offline  
post #5 of 12 Old 03-22-2010, 11:40 AM Thread Starter
1st Gear
 
Join Date: Nov 2005
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by SatinSilver View Post
I forget the code but it translated to "fuel system lean" and it was the fuel pressure regulator on a 99 lx I4. There was a tsb for this but warranty didn't cover it since I was WAY over on the warranty. I know it doesn't answer your question completely but wanted to pass along the info.

Do you remember what the fix was?
mickey1987 is offline  
post #6 of 12 Old 03-22-2010, 02:37 PM
6th Gear
 
ry05coupe's Avatar
 
Join Date: Feb 2009
Location: Lexington, KY
Posts: 1,417
Thanks: 0
Thanked 2 Times in 2 Posts
My bad I was thinking about my 05, didnt notice the year of yours.

Latest mod: 35W 3000K Fogs.


2005 Accord Coupe i4
ry05coupe is offline  
post #7 of 12 Old 03-22-2010, 03:47 PM
Moderator
 
Fredsvt's Avatar
 
Join Date: May 2004
Location: Morganville, NJ
Posts: 4,369
Thanks: 0
Thanked 11 Times in 10 Posts
Lean codes can be caused by a number of different things.

I'd need to know when it takes place, as in freeze frame data from when the code stored.

I'd also need to know MAP voltage readings at hot idle, fuel trim values at idle, 2500 no load, and steady state 45 mph cruise.

I'd also like to see a graph of the air/fuel sensor readings.

The car must be free of exhaust leaks both near the primary air/fuel sensor, and after the cat within about 18".

Sapphire blue '04 V6 6 speed w/ full HFP, comptech ss, momo shadow, TL-S 27.2h/20 bars, intake spacer, retro chrome MH1 HIR2 highs, hella DE fogs, EBC Ultimax, subwoofer/amp, infinity rears, HD Radio, aux adapter, navi conversion.

Vermilion 1999 SVT F150 Lightning, Sylvania/Visteon Xenarc HID headlamps, '01 L turn/marker lamps, PIAA fogs, '01 up Bilstein shocks, all Pioneer speakers, Clarion subwoofer. All Redline fluids.

Silverstone 2003 Honda S2000, bone stock
Fredsvt is offline  
post #8 of 12 Old 03-23-2010, 06:34 AM
Moderator
 
SatinSilver's Avatar
 
Join Date: Mar 2007
Location: Ohio
Posts: 6,286
Thanks: 38
Thanked 104 Times in 64 Posts
Quote:
Originally Posted by mickey1987 View Post
Do you remember what the fix was?
In my case it was the fuel pressure regulator BUT like Fredsvt said it can be caused by many different things. I took mine to the dealer for the diagnosis and it ran $95 installed.
SatinSilver is offline  
post #9 of 12 Old 03-30-2010, 07:52 AM Thread Starter
1st Gear
 
Join Date: Nov 2005
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
Just wanted to update..
I found a Delphi FP10198 Fuel Injection Pressure Regulator replacement for 23.22 . It took about 10 min to change and no CEL for 5 days now.

Thanks for all the help!!
mickey1987 is offline  
post #10 of 12 Old 07-15-2010, 06:43 PM
1st Gear
 
Join Date: Oct 2008
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
P0171 system too lean bank1
P2A00 OXYGEN SENSOR BANK 1 SENSOR 1

should i replace the o2 sensor first or the fuel pressure regulator or both since the cost is not that high .
maniek is offline  
post #11 of 12 Old 07-15-2010, 09:01 PM
1st Gear
 
Join Date: Oct 2008
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
In addition where is bank 1 sensor 1 o2 sensor located
maniek is offline  
post #12 of 12 Old 07-16-2010, 03:17 PM
Moderator
 
Fredsvt's Avatar
 
Join Date: May 2004
Location: Morganville, NJ
Posts: 4,369
Thanks: 0
Thanked 11 Times in 10 Posts
B1S1 is the first sensor in the system in a 4 with only two sensors.

On a V6 with more than 2 sensors, it's the rear bank front sensor.

Sapphire blue '04 V6 6 speed w/ full HFP, comptech ss, momo shadow, TL-S 27.2h/20 bars, intake spacer, retro chrome MH1 HIR2 highs, hella DE fogs, EBC Ultimax, subwoofer/amp, infinity rears, HD Radio, aux adapter, navi conversion.

Vermilion 1999 SVT F150 Lightning, Sylvania/Visteon Xenarc HID headlamps, '01 L turn/marker lamps, PIAA fogs, '01 up Bilstein shocks, all Pioneer speakers, Clarion subwoofer. All Redline fluids.

Silverstone 2003 Honda S2000, bone stock
Fredsvt is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Drive Accord Honda Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
The answer to the random question may be found under the Off Topic section of the forums and in the "Drive Accord Forums" category.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome