Reset the Check Engine Light - Drive Accord Honda Forums
Reply
 
LinkBack Thread Tools Search this Thread Rating: Thread Rating: 82 votes, 5.00 average. Display Modes
post #1 of 18 Old 01-07-2011, 01:20 PM Thread Starter
1st Gear
 
Join Date: Dec 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Reset the Check Engine Light

Does anyone know how to do a DIY reset of the check engine light? Had a HID kit installed and the light came on afterwards. Seems like a normal thing after researching. I called the local dealership and they said only way to clear it is by paying them $70 and running a programmer.

I know our other vehicles can be soft reset, and I understand earlier models could as well. So can anyone save me some time and money at the stealership?

Thanks
Citadel is offline  
Sponsored Links
Advertisement
 
post #2 of 18 Old 01-07-2011, 01:36 PM
Should Have Went 5peed
 
HaCk3rx's Avatar
 
Join Date: Mar 2009
Location: The O.C
Posts: 309
Thanks: 0
Thanked 0 Times in 0 Posts
I dont think you can reset it... it turns on for a reason so i think youhave to find out what triggered it and fix it.

|2009 EX Coupe|BlackonBlack|
| TSX RSB|
| Tint 20/5 |
| HID 5000k |
| LED Interior |
| Odyssey Grille |
| Weather Tech Visors |
| OEM Rear Wing Spoiler |
| Type 2 DUAL Turn Signals |
| Nokya Yellow Fogs w/ Yellow Lamin-X Film |


If Life Gives you Drama, Let VTEC Kick in!
HaCk3rx is offline  
post #3 of 18 Old 01-07-2011, 02:09 PM
Super Moderator
 
Aviography's Avatar
 
Join Date: Jul 2007
Location: Canada
Posts: 9,263
Thanks: 36
Thanked 183 Times in 133 Posts
OP,

While some cars throw an error code when HID is installed, the 8th Gen Accord does not appear to be one of them, at least not based on experiences seen here on DA over the past couple of years.

Resetting the code when the prevailing fault is not fixed means the CEL will just return sometime later, you might as well just donate the $70 to your favorite charity!

You should have the code read (typically for free) by local PepBoy, AutoZone etc. to find out what the code points to, HID is most likely not the cause.

2005 Satin Silver V6 Coupe 6 speed, Venture Shield clear protetive film,
TL shift knob, Hidden Hitch,
GM Friction Modified Synchromesh transmission fluid
2007 Acura TL-S front/rear sway bars,
Clutch slave cylinder restrictor valve delete.

Acura TL 5-spoke rims 245/45-17 Bridgestone Pole Position RE970
Honda steel rims 225/55-16 Michelin Alpin PA2


__________________
DA Moderator Team

DriveAccord.Net Forum Rules & Regs
DriveAccord.net Classified Rules
Aviography is offline  
post #4 of 18 Old 01-07-2011, 03:30 PM
NJDR
 
peter01592's Avatar
 
Join Date: Dec 2009
Location: Edison, NJ / Pocono Summit, PA
Posts: 864
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by aviography View Post
op,

while some cars throw an error code when hid is installed, the 8th gen accord does not appear to be one of them, at least not based on experiences seen here on da over the past couple of years.

Resetting the code when the prevailing fault is not fixed means the cel will just return sometime later, you might as well just donate the $70 to your favorite charity!

You should have the code read (typically for free) by local pepboy, autozone etc. To find out what the code points to, hid is most likely not the cause.
+1+1+1

2009 honda accord coupe ex-l v6
MODS:

To many to list.
peter01592 is offline  
post #5 of 18 Old 01-07-2011, 03:43 PM
Sugar coating for you ..
 
Danielc409's Avatar
 
Join Date: Apr 2009
Location: Port Arthur, TX
Posts: 6,121
Thanks: 0
Thanked 4 Times in 4 Posts
You can reset it by disconnecting the battery but it will eventually show back up if there is still a problem but yea HID's won't cause a check "engine" light.

2011 Subaru STi - Stage 2 - Plasma Blue Pearl

My member journal / build thread @ IWSTI

2008 Honda Accord Coupe V-6 EX-L AT NBP
No longer owned
Danielc409 is offline  
post #6 of 18 Old 01-07-2011, 06:00 PM Thread Starter
1st Gear
 
Join Date: Dec 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks all, I will have the code pulled tomorrow.
Citadel is offline  
post #7 of 18 Old 01-07-2011, 06:19 PM
avs
4th Gear
 
Join Date: Dec 2008
Location: NoVA
Posts: 399
Thanks: 0
Thanked 0 Times in 0 Posts
You can buy a OBD II reader for 20-30 bux at your local walmart.
avs is offline  
post #8 of 18 Old 01-07-2011, 08:40 PM
3rd Gear
 
Join Date: May 2009
Posts: 134
Thanks: 0
Thanked 0 Times in 0 Posts
Sometimes the local auto store will allow you to clear the code after they tell you what it is.

Although it's not legal to just clear the code without fixing the problem, i have heard they will check the codes and when it comes to the point to clear the code on the diagnostic tool they will say "we can not clear the code for you, but if you push this button you will clear your code" this takes the liability away from them and puts it on you, because you cleared the code.

2010 Accord Coupe - Black - V6 - 6 spd
xpshooter is offline  
post #9 of 18 Old 01-08-2011, 09:37 AM
Honda Nation
 
Join Date: Dec 2005
Location: Cleveland, OH
Posts: 1,922
Thanks: 0
Thanked 64 Times in 49 Posts
The check engine light on all OBDII (all 1996 and later North American vehicles) vehicles reflects an issue with something in the emission controls, fuel delivery, ignition, timing, or exhaust system. Not related to electrical which it seems you may be correlating it to based on your presumption that it is related to your HID install.

It's just a coincidence it came on after you did your HIDs. You should have it checked..... your car should still be under warranty so your dealer should run the codes and repair the problem for free, unless you have over 60k on it (remember Honda warranty is 3/36 bumper to bumper and 5/60 on drivetrain)

If there was an electrical issue your battery or alternator indicator lamp would illuminate.

May 2009 - Present: 2009 Accord V6 6 MT coupe w/o nav, Alabaster Silver

Dec. 1999 - May 2010: 2000 Prelude 5 MT, sold with 220,000 miles and still running great - gone, but not forgotten
fastball is offline  
post #10 of 18 Old 01-08-2011, 02:17 PM Thread Starter
1st Gear
 
Join Date: Dec 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by fastball View Post
The check engine light on all OBDII (all 1996 and later North American vehicles) vehicles reflects an issue with something in the emission controls, fuel delivery, ignition, timing, or exhaust system. Not related to electrical which it seems you may be correlating it to based on your presumption that it is related to your HID install.

It's just a coincidence it came on after you did your HIDs. You should have it checked..... your car should still be under warranty so your dealer should run the codes and repair the problem for free, unless you have over 60k on it (remember Honda warranty is 3/36 bumper to bumper and 5/60 on drivetrain)

If there was an electrical issue your battery or alternator indicator lamp would illuminate.
Right you are. Took it to the dealership today, called us in the back and began telling us the O2 sensor was faulty. I asked him how and we walked under the car on a lift to see that a damn rat or something had chewed through the harness/wire. Here's the real damage...it's going to cost ~$400 to replace both harness and sensor, and apparently such damage is not covered under warranty.
Citadel is offline  
post #11 of 18 Old 01-08-2011, 03:01 PM
Sugar coating for you ..
 
Danielc409's Avatar
 
Join Date: Apr 2009
Location: Port Arthur, TX
Posts: 6,121
Thanks: 0
Thanked 4 Times in 4 Posts
Did the dealer tell you that or is that how it actually looks.

2011 Subaru STi - Stage 2 - Plasma Blue Pearl

My member journal / build thread @ IWSTI

2008 Honda Accord Coupe V-6 EX-L AT NBP
No longer owned
Danielc409 is offline  
post #12 of 18 Old 01-09-2011, 05:10 AM Thread Starter
1st Gear
 
Join Date: Dec 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Danielc409 View Post
Did the dealer tell you that or is that how it actually looks.
I'll admit it looked legit. We walked into their service garage and had the car on a lift so we walked under it, and low and behold...two spots where the wire had been chewed and mangled.
Citadel is offline  
post #13 of 18 Old 01-09-2011, 05:35 AM
2nd Gear
 
Join Date: Dec 2009
Location: Pittsburgh, PA
Posts: 82
Thanks: 0
Thanked 0 Times in 0 Posts
400 bucks? Really? I do not know the extent of your damage, but if it were me, I'd splice/solder/patch the wiring. I would also use heat shrink tubing to protect the repair. Unless the wiring was completely obliterated, I see no reason why a decent mechanic or auto electric shop could not make a full repair of the existing wiring (for a lot less money).

1988 Chrysler LeBaron 2.2L Turbo Convertible (original owner)
1989 Chevrolet Beretta GT 2.8L (original owner)
1996 Chrysler Town & Country 3.8L
2009 Honda Accord EX Sedan 2.4L (original owner)
pghturbo88 is offline  
post #14 of 18 Old 06-07-2012, 06:47 PM
My First Post
 
Join Date: Jun 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Well as a guy that just replaced the o2 sensor in my 2007 I can say the "harness" is part of the sensor. The "harness" is 30 inches long and runs continuous from the sensor s rewed into the catalytic converter thru 4 clips (provided) to a rubber plug on the floor provided to a clip plug under the passenger seat. Undo the passenger seat w a 14mm wrench and the connection. Is obvious. There is no harness. Just a sensor with a long wire sold to me at autozone for 62 bucks with 25 dollars to use the special slotted socket set. The 25 comes back when I return it.

Granted it was a pita to get under the car, unbolt the seat, buy the part, return the tool and reset the light but 300 bucks saved gave me the chance to do this w my 20 year old son.

You probably did right taking it in as jacking and blocking up a car isn't for everyone.
Booch is offline  
post #15 of 18 Old 06-07-2012, 07:02 PM
4th Gear
 
PatronTequila's Avatar
 
Join Date: Mar 2010
Posts: 340
Thanks: 0
Thanked 1 Time in 1 Post
Rats are known to chew through wiring, that' why Honda even has "Rodent Deterrent Tape":

http://www.bernardiparts.com/products/4019-2317.aspx
PatronTequila is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Drive Accord Honda Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
The answer to the random question may be found under the Off Topic section of the forums and in the "Drive Accord Forums" category.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome