TCS & Engine light went on & D4 blinking...what happend?? - Drive Accord Honda Forums
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
post #1 of 13 Old 04-14-2010, 10:31 AM Thread Starter
1st Gear
 
prowler220x's Avatar
 
Join Date: Mar 2010
Location: Bay Area
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
TCS & Engine light went on & D4 blinking...what happend??

So today I'm driving down the street and all of a sudden my TCS & Check Engine lights turn on and my D4 lights starts blinking. I pull over, turn the car off then back on and the TCS light is off the the D4 is now solid like it should but the Check Engine light is still on.

Before I go out and get the engine light checked out for the code to find out what it's reading, has anyone experienced this before? What happend??
prowler220x is offline  
Advertisement
 
post #2 of 13 Old 04-14-2010, 10:43 AM
Out of Control
 
cajun's Avatar
 
Join Date: Dec 2007
Location: Southeast
Posts: 2,055
Thanks: 7
Thanked 11 Times in 10 Posts
Is it shifting okay? What color is your ATF and is it at the correct level? Hope I'm wrong, but your trans might be giving you an early warning.

2010 PMM Accord LX-P, TSX rear sway, GG lower grille, 35% tint, 50K+
2006 Toyo Sienna LE, 100K+
2002 Accord SE (sold), TL rear sway and upper strut bars
cajun is offline  
post #3 of 13 Old 04-14-2010, 10:49 AM Thread Starter
1st Gear
 
prowler220x's Avatar
 
Join Date: Mar 2010
Location: Bay Area
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
I've only had the car for about a month and haven't noticed any changes in the shifting since I purchased it. The ATF fluid is a reddish color and it's at the correct level.
prowler220x is offline  
post #4 of 13 Old 04-14-2010, 01:10 PM
Aspiring Tuner
 
AccordLXMaster's Avatar
 
Join Date: Nov 2009
Location: Dallas (Mesquite)
Posts: 1,105
Thanks: 0
Thanked 0 Times in 0 Posts
blinking d4 light.....is a VSS(vehicle speed sensor)

EDIT: also indicates problems with the tranny....sorry

JDM F23A Swap Done!!

98 LX

ENGINE MODS
-Spectre CAI
-Flowmaster 40 Series
-NGK G-Power Plugs
-4-2-1 Header
-CherryBomb GlassPack Resonator

COSMETIC MODS
-Double 5% Tint
-Twin Halo Projectors
-Bright White LED Turn Signals
-DDM Tuning 6000k 35w

SUSPENSION MODS
-Megan Strut Bar

AccordLXMaster is offline  
post #5 of 13 Old 04-14-2010, 01:53 PM Thread Starter
1st Gear
 
prowler220x's Avatar
 
Join Date: Mar 2010
Location: Bay Area
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
I guess replace it with one of these & then see how it goes?
http://www.partstrain.com/ShopByDepa...r/HONDA/ACCORD

Anyone experience what I mentioned in the first post?
prowler220x is offline  
post #6 of 13 Old 04-15-2010, 08:32 AM
Out of Control
 
cajun's Avatar
 
Join Date: Dec 2007
Location: Southeast
Posts: 2,055
Thanks: 7
Thanked 11 Times in 10 Posts
Quote:
Originally Posted by prowler220x View Post
I guess replace it with one of these & then see how it goes?
See how it goes? Pull your CEL code before you start replacing parts.

2010 PMM Accord LX-P, TSX rear sway, GG lower grille, 35% tint, 50K+
2006 Toyo Sienna LE, 100K+
2002 Accord SE (sold), TL rear sway and upper strut bars
cajun is offline  
post #7 of 13 Old 04-15-2010, 08:56 AM Thread Starter
1st Gear
 
prowler220x's Avatar
 
Join Date: Mar 2010
Location: Bay Area
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Of course, I'm getting that checked today before I order any parts
prowler220x is offline  
post #8 of 13 Old 04-15-2010, 09:29 AM
In one place & one accord
 
ShortTom's Avatar
 
Join Date: Mar 2010
Posts: 100
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by prowler220x View Post
I guess replace it with one of these & then see how it goes?
http://www.partstrain.com/ShopByDepa...r/HONDA/ACCORD

Anyone experience what I mentioned in the first post?
Accord to the Honda OwnerLink extended transmission warranty statement:

" These characteristics are not normal; if you experience any of them, call your Honda dealer.

* While driving, the D4 indicator on the instrument panel flashes.




* An abnormally loud noise from the transmission.
* Extremely slow or delayed gear engagement, upshifts, or downshifts.
* Abnormal gear slippage during upshifts or downshifts.
* Erratic or excessively harsh shifting.
* Automatic transmission fluid (ATF) leaks.

In the next few weeks, owners of potentially affected vehicles will be sent a copy of this letter along with reimbursement instructions in case they previously paid to have the transmission repaired or replaced.

It's important to maintain your vehicle's transmission according to the maintenance schedule in your owner's manual. Not maintaining the transmission properly can void the warranty coverage.

Thank you for your understanding and cooperation in this matter.

Sincerely,

AMERICAN HONDA MOTOR CO., INC.
Honda Automobile Division "


I guess that's mainly no helpful other than indicating it's not a normal scenario. What year and mileage is on your Honda? I spoke to a Honda tech the other day that said even if your vehicle's out of warranty Honda will "work with you" on a transmission replacement. The extended warranty I'm talking about is for 98-01 models and covers 7 years/100,000 miles, whichever comes first so you're def out of warranty. Unless there's another tranny recall on later models.

2001 Naples Gold Metallic Accord EX V6 Coupe that I want to look EXACTLY like goldnknight22's.
ShortTom is offline  
post #9 of 13 Old 04-15-2010, 10:10 AM Thread Starter
1st Gear
 
prowler220x's Avatar
 
Join Date: Mar 2010
Location: Bay Area
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
It's got around 107,300 miles on it. It shifts pretty smoothly and the tranny's not making any loud noises.

1st to 2nd gear doesn't happen as quick as it did on previous car's I've owned unless I push down a bit harder on the gas pedal but I'm assuming that's because of the transmission and not an indicator of a problem

I'll know more after I get the CEL code
prowler220x is offline  
post #10 of 13 Old 04-15-2010, 10:46 AM
Aspiring Tuner
 
AccordLXMaster's Avatar
 
Join Date: Nov 2009
Location: Dallas (Mesquite)
Posts: 1,105
Thanks: 0
Thanked 0 Times in 0 Posts
yeah just pull the code...

JDM F23A Swap Done!!

98 LX

ENGINE MODS
-Spectre CAI
-Flowmaster 40 Series
-NGK G-Power Plugs
-4-2-1 Header
-CherryBomb GlassPack Resonator

COSMETIC MODS
-Double 5% Tint
-Twin Halo Projectors
-Bright White LED Turn Signals
-DDM Tuning 6000k 35w

SUSPENSION MODS
-Megan Strut Bar

AccordLXMaster is offline  
post #11 of 13 Old 04-16-2010, 11:46 AM Thread Starter
1st Gear
 
prowler220x's Avatar
 
Join Date: Mar 2010
Location: Bay Area
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Got the code read:

PO780 - Shift Malfunction

They turned the light off and said if it goes back on then it's really a problem. Anyone deal with this? The car still shift and sounds pretty smooth so I'm hoping if maybe replacing the fluid and the filter in the tranny will keep this problem at bay.
prowler220x is offline  
post #12 of 13 Old 04-16-2010, 12:13 PM
Moderator
 
CDsDontBurn's Avatar
 
Join Date: Aug 2009
Location: SoCal, 92220
Posts: 4,040
Thanks: 76
Thanked 94 Times in 84 Posts
i did. but my transmission was already a gonner at the time. a few days after this started happening to me and i got that code, i took my car to a shop to have the tranny rebuilt.

you say yours is shifting fine, so maybe it just happened once or twice. keep an eye on it to see if it comes back. on my car when it happened, it was slipping a lot between all 3 gear changes: 1st to 2nd, 2nd to 3rd, 3rd to 4th.

2000 2dr. v6 Accord | Limo Tint | Black housing Crystal Headlights | Greddy MX Exhaust | K&N Drop-in Filter | Magnaflow Hi-Flow CAT | R1 Concept slotted/ventilated rotors - Front | Eibach Pro Springs | KYB-GR2 Shocks | Eibach Sway Bars | DC Strut Bar | 6000k HIDs | Pioneer DEH-P6000UB | Pioneer mid speakers | Matt Tweeters | Kenwood 4ch. 800w Amp | 2x 10" Sony Xplod 800w subs | Sony 1200w Class D Amp
CDsDontBurn is offline  
post #13 of 13 Old 04-16-2010, 08:50 PM
In one place & one accord
 
ShortTom's Avatar
 
Join Date: Mar 2010
Posts: 100
Thanks: 0
Thanked 0 Times in 0 Posts
Lightbulb

Quote:
Originally Posted by prowler220x View Post
Got the code read:

PO780 - Shift Malfunction

They turned the light off and said if it goes back on then it's really a problem. Anyone deal with this? The car still shift and sounds pretty smooth so I'm hoping if maybe replacing the fluid and the filter in the tranny will keep this problem at bay.
Sure couldn't hurt. I'm like CDs you pretty much have to wait and she what does.

2001 Naples Gold Metallic Accord EX V6 Coupe that I want to look EXACTLY like goldnknight22's.
ShortTom is offline  
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Drive Accord Honda Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
The answer to the random question may be found under the Off Topic section of the forums and in the "Drive Accord Forums" category.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome