96 Accord speedometer sticking - Drive Accord Honda Forums

Go Back   Drive Accord Honda Forums > Honda Accord Main Forums > The Early Generations

Drive Honda Accord Forums
Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 08-27-2009, 04:15 AM
ccparch57 ccparch57 is offline
1st Gear
 
Join Date: Aug 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy 96 Accord speedometer sticking

My 1996 Accord's speedometer occasionally sticks around the 20 mph location, and causes the odometer and trip meter to stop working. Other than replacing the whole cluster, is there a way to repair this? Also, if I replace it, is it possible to adjust the mileage to match my existing odometer?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-27-2009, 04:17 AM
A&Fbro28's Avatar
A&Fbro28 A&Fbro28 is offline
Out of Control
 
Join Date: Dec 2007
Location: Wilmington, NC
Posts: 2,879
Thanks: 0
Thanked 1 Time in 1 Post
Send a message via AIM to A&Fbro28 Send a message via Yahoo to A&Fbro28
Time for a new speed sensor. It isnt much money that i can remember.
__________________
Desmond,

08 Acura TL w/Technology Pkg

08 Taffeta White Honda Accord EX-L w/Navi Coupe (traded-in)
http://www.cardomain.com/ride/3093726
Reply With Quote Quick reply to this message
  #3  
Old 08-28-2009, 11:21 AM
12153 12153 is offline
banned
 
Join Date: Feb 2009
Posts: 3,170
Thanks: 0
Thanked 3 Times in 3 Posts
CCParch57:

Is your speedo solid-state (electronic)? Or old-style (mechanical) with cable drive?
Reply With Quote Quick reply to this message
  #4  
Old 08-30-2009, 03:28 PM
ItsaHonda's Avatar
ItsaHonda ItsaHonda is offline
6th Gear
 
Join Date: Nov 2005
Location: Orlando, FL
Posts: 1,847
Thanks: 0
Thanked 0 Times in 0 Posts
The 5th gen gauge cluster is electronic, not cable-driven... ditto for the 4th gen. The VSS (vehicle speed sensor) is a common problem on the older Accords, so it is certainly a possibility... but my experience with a VSS failure has been an entirely non-functioning speedometer, not just an intermittent pause. I would say to check the cruise control when the speedometer sticks, but I'm not certain that it even engages at 20 mph. If the VSS has failed or is failing, the cruise control will be inop.
__________________
1990 Honda Accord LX coupe
130,XXX miles


1989 Honda Accord LX sedan
186,XXX miles


1998 Lexus GS400
170,XXX miles


1992 Cadillac Allante
70,XXX miles


2013 Kia Optima LX
8,xxx miles
Reply With Quote Quick reply to this message
  #5  
Old 08-30-2009, 03:42 PM
12153 12153 is offline
banned
 
Join Date: Feb 2009
Posts: 3,170
Thanks: 0
Thanked 3 Times in 3 Posts
ItsaHonda:

Thanks for the enlightenment. Were I not so lazy, I would look it up.

This represents a techno change from my 3rd Gen...which has a cable-driven, mechanical speedo. Its speed sensor unit governs (only) cruise control operation.
Reply With Quote Quick reply to this message
  #6  
Old 09-09-2009, 01:41 PM
ccparch57 ccparch57 is offline
1st Gear
 
Join Date: Aug 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
I have determined pretty much that it is my speedometer, so I was able to obtain a used one (entire cluster) at a Honda salvage parts place. I have figured out how to replace it, but now my problem is I can't get the trim off the console in order to get at the cluster. I removed the two screws underneath in front of the cluster and I can get that side pulled out, but I can't get the side above where the radio sits out. I have removed the two HVAC knobs, but it appears to be attached on that side. Is there another screw or something that has to come out?
Reply With Quote Quick reply to this message
  #7  
Old 09-15-2009, 11:10 AM
h22accord h22accord is offline
1st Gear
 
Join Date: Sep 2009
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by A&Fbro28 View Post
Time for a new speed sensor. It isnt much money that i can remember.
i was going to say the same thing

check speed sensor
Reply With Quote Quick reply to this message
  #8  
Old 09-15-2009, 01:48 PM
Shadow Works's Avatar
Shadow Works Shadow Works is offline
Always in reverse
 
Join Date: Sep 2009
Location: Scotland
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Where is this speed sensor located guys?
Reply With Quote Quick reply to this message
  #9  
Old 09-25-2009, 11:42 PM
htekken's Avatar
htekken htekken is offline
dont deviate
 
Join Date: Mar 2009
Location: SLTX
Posts: 312
Thanks: 0
Thanked 1 Time in 1 Post
the VSS is tough to spot. it sits on top of tranny but towards the back. even in daylight it can be hard to see since its deep in the bay, so a flashlight would help. hard to replace cuz its hard to reach, i know, i did this last month.

OP how exactly did you determine it was the cluster? i know this thread is kinda old but curious cuz it sounds like a vss problem to me. my symptoms were, speedo needle went crazy up and down while driving, then just stopped moving completely, trip odom stopped working, odometer stopped working, and got the occasional CEL.
__________________
/94EX CD7 G77M/DZ-D1/JDM S2K HID/18RH-C5/WW-T/(gone)
/07SE CM5 NH700M/17V6-6/OEM LIP/Decklid/Hybrid LED/TSX HID/
/02IS BD1 B01B 8N8/
Reply With Quote Quick reply to this message
  #10  
Old 11-02-2009, 01:03 PM
ccparch57 ccparch57 is offline
1st Gear
 
Join Date: Aug 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Speedometer replacement

I determined it was the speedometer cluster based on what my normal mechanic told me. He had suggested I could replace it myself, so I found one at a Honda salvage yard near me. The problem I have had is getting the cover off so that I can remove the cluster. I can see that it is held in by clips, but for the life of me I cannot get it loose, especially around the heater vents above the radio. Is there a special tool for this?
Reply With Quote Quick reply to this message
  #11  
Old 11-04-2009, 09:15 AM
htekken's Avatar
htekken htekken is offline
dont deviate
 
Join Date: Mar 2009
Location: SLTX
Posts: 312
Thanks: 0
Thanked 1 Time in 1 Post
no. did you trying using a flathead to pry? its been a while since i removed the gauge cluster so i dont member whut i did.
__________________
/94EX CD7 G77M/DZ-D1/JDM S2K HID/18RH-C5/WW-T/(gone)
/07SE CM5 NH700M/17V6-6/OEM LIP/Decklid/Hybrid LED/TSX HID/
/02IS BD1 B01B 8N8/
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Drive Accord Honda Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
The answer to the random question may be found under the Off Topic section of the forums and in the "Drive Accord Forums" category.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 06:02 AM.




Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.