EGR valve replaced, check engine light still comes on! - Drive Accord Honda Forums

Go Back   Drive Accord Honda Forums > The Honda Accord Lab > Problems & Solutions

Drive Honda Accord Forums
Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 08-06-2010, 09:20 PM
glpc98 glpc98 is offline
1st Gear
 
Join Date: Aug 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
EGR valve replaced, check engine light still comes on!

Hello to all,

I'm in a desparate need for help on this matter.

I have 98 accord LX V6 with 164k miles. Well, I took this car in for inspection and found out it failed. The reason was 1) P0401 code, and 2) check engine light bulb was missing.

I came home and took the dash out and discovered the check engine light bulb was physically taken out. Of course, when I bought this car used, the seller did not mention anything about the 'glitch.' I found out that he had a problem on the same issue and instead of fixing it, it mysteriously took care of the check engine light and managed to pass the state inspection before he sold the car to me. (shouldn't he be thrown in jail for this?)

Now I'm stuck with this problem and need to take care of it the right way to pass the inspection. I found out that O2 sensor and mass air flow sensor were replaced and I replaced EGR vavle a couple days ago. The result? The bright yellow 'check engine light.'! Can someone please help me on this? I am very tired of throwing money into this money pit and willing to get this thing fixed and move on with my life. I really appreciate any advice!

JL
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-07-2010, 05:07 PM
Fredsvt's Avatar
Fredsvt Fredsvt is offline
Moderator
 
Join Date: May 2004
Location: Morganville, NJ
Posts: 4,368
Thanks: 0
Thanked 7 Times in 7 Posts
The car doesn't have a mass air flow sensor. A 1998 is speed density and only has a map sensor.

Replacing the EGR valve for a low flow code is putting the cart before the horse. Without testing to see if the valve actually works, and whether the port in the intake is blocked. A very, very, very common issue on V6s. (blocked port)

You need to pull the upper intake and manually clean out the port in the upper intake. Take off the EGR valve and clean the port from the lower intake to the EGR base in the water crossover.

Once you're done cleaning it out, clear the codes. Test drive the car and within the first 5 miles or so, get it over 60 and coast for at least 5 to 10 seconds, it will test the EGR system for flow during this time. The light should stay off as long as the ports are clear.

Do a search, there's several good threads with pics.
__________________
Sapphire blue '04 V6 6 speed w/ full HFP, comptech ss, momo shadow, TL-S 27.2h/20 bars, intake spacer, retro chrome MH1 HIR2 highs, hella DE fogs, EBC Ultimax, subwoofer/amp, infinity rears, HD Radio, aux adapter, navi conversion.

Vermilion 1999 SVT F150 Lightning, Sylvania/Visteon Xenarc HID headlamps, '01 L turn/marker lamps, PIAA fogs, '01 up Bilstein shocks, all Pioneer speakers, Clarion subwoofer. All Redline fluids.

Silverstone 2003 Honda S2000, bone stock
Reply With Quote Quick reply to this message
  #3  
Old 08-07-2010, 06:43 PM
glpc98 glpc98 is offline
1st Gear
 
Join Date: Aug 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Thank you for your help! I will try to get this thing cleaned and see if the check engine light stays off!
Reply With Quote Quick reply to this message
  #4  
Old 09-07-2010, 09:43 AM
janiras janiras is offline
My First Post
 
Join Date: Sep 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by glpc98 View Post
hello to all,

i'm in a desparate need for help on this matter.

I have 98 accord lx v6 with 164k miles. Well, i took this car in for inspection and found out it failed. The reason was 1) p0401 code, and 2) check engine light bulb was missing.

I came home and took the dash out and discovered the check engine light bulb was physically taken out. Of course, when i bought this car used, the seller did not mention anything about the 'glitch.' i found out that he had a problem on the same issue and instead of fixing it, it mysteriously took care of the check engine light and managed to pass the state inspection before he sold the car to me. (shouldn't he be thrown in jail for this?)

now i'm stuck with this problem and need to take care of it the right way to pass the inspection. I found out that o2 sensor and mass air flow sensor were replaced and i replaced egr vavle a couple days ago. The result? The bright yellow 'check engine light.'! Can someone please help me on this? I am very tired of throwing money into this money pit and willing to get this thing fixed and move on with my life. I really appreciate any advice!

Jl
hey i was wondering if you got your check engine light off? I have the same problem with the same car, got my bro to clean out the egr valve and check eng light still on
Reply With Quote Quick reply to this message
  #5  
Old 09-07-2010, 03:45 PM
Fredsvt's Avatar
Fredsvt Fredsvt is offline
Moderator
 
Join Date: May 2004
Location: Morganville, NJ
Posts: 4,368
Thanks: 0
Thanked 7 Times in 7 Posts
cleaning the valve will NOT fix a P0401
You need to remove the intake and clean the port in the upper manifold and the port from the lower manifold to the valve.
__________________
Sapphire blue '04 V6 6 speed w/ full HFP, comptech ss, momo shadow, TL-S 27.2h/20 bars, intake spacer, retro chrome MH1 HIR2 highs, hella DE fogs, EBC Ultimax, subwoofer/amp, infinity rears, HD Radio, aux adapter, navi conversion.

Vermilion 1999 SVT F150 Lightning, Sylvania/Visteon Xenarc HID headlamps, '01 L turn/marker lamps, PIAA fogs, '01 up Bilstein shocks, all Pioneer speakers, Clarion subwoofer. All Redline fluids.

Silverstone 2003 Honda S2000, bone stock
Reply With Quote Quick reply to this message
  #6  
Old 08-01-2011, 12:48 PM
Happiours Happiours is offline
1st Gear
 
Join Date: Aug 2011
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
I just replaced the EGR valve and the light is still on. How does one clear the codes?
BTW a continuity check of pin positions 1 and 2 showed open. That is why I went ahead and replaced the whole assembly and did not try to clean it.

tom
Reply With Quote Quick reply to this message
  #7  
Old 08-01-2011, 02:08 PM
Happiours Happiours is offline
1st Gear
 
Join Date: Aug 2011
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
EGR valve replacement

I just found the answer to my question. Once the EGR valve is replaced, one has to pull the #13 fuse (by the passenger side door opening) to reset the electronics. The "Check engine light" is no longer lit. It worked for me thank goodness.

Tom
Reply With Quote Quick reply to this message
  #8  
Old 02-18-2014, 07:20 AM
Eric connolly Eric connolly is offline
My First Post
 
Join Date: Feb 2014
Location: Central Valley California
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Is this fix the same on a 4 cyl
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
check engine light, egr valve

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Drive Accord Honda Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
The answer to the random question may be found under the Off Topic section of the forums and in the "Drive Accord Forums" category.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 05:58 PM.




Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.