O2 Sensor Changed, Check Engine Light Still on...? Will it go off? - Drive Accord Honda Forums

Go Back   Drive Accord Honda Forums > Honda Accord Main Forums > The 7th Generation

Drive Honda Accord Forums
Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 02-04-2011, 03:37 AM
redbug2 redbug2 is offline
1st Gear
 
Join Date: Feb 2011
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
O2 Sensor Changed, Check Engine Light Still on...? Will it go off?

Hello,

My mothers 2004 Accord had its Check Engine Light come on. She tried the gas cap tightening and that did not work. I had her take it to Autozone and they read the code on the computer. O2 sensor. She bought the Bosch O2 sensor that I changed yesterday.

That was not as easy as I thought.. Jacked up the car and had to remove the pipe from manifold. Not enough room to get socket on 02 sensor. Removed bolts from the exhaust mount and dropped down the front end of entire exhaust. Kept exhaust propped up about 5 inches because Cat sensor was still wired in and at its length limit. Then, vise gripped the flange end while I turned the special socket to remove the O2 sensor. That's tough because of the flexible joint on the pipe, you need to anchor flange before loosening 02 sensor.

Anyway, 02 sensor is in. Drove the car about 25 miles and the light is still on.

Will the light eventually go off by itself? (If the O2 sensor was the problem and is now fixed?) Or, do I have to somehow reset the check engine light? Autozone did state that they would not turn off the light.

Thanks,

redbug2
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-04-2011, 03:58 AM
mobiless2's Avatar
mobiless2 mobiless2 is offline
mobiless2
 
Join Date: Sep 2009
Location: Florida
Posts: 1,611
Thanks: 9
Thanked 58 Times in 52 Posts
Have to get code cleared. I purchased a code reader from Autozone for $39.99 & cleared the code.
__________________
2005 SSM LX I-4 Auto Sedan: TL-S FSB / TL-S RSB / Tokico HTS Shocks / Neuspeed Sport Springs / 18" Element SC Wheels / 225-45-18 / TSX Rotors / CR-V Dual Piston Calipers / Drum to Disk Conversion / SS Brake Lines / K&N SRI / Japspeed TSX Header / TSX IM / P2R Thermal Gaskets / Ralco Pulleys / HFP Front Lip / OEM Deck Lid Spoiler / TSX Mirrors / OEM Fogs / HID Retro-Fit / K40 261K

2009 ASM EX I-4 Auto Sedan: Weapon-R I Throttle / TL FSB & RSB / Morimoto H1 / OEM Fog / K40 / Viper 5704 125K
Reply With Quote Quick reply to this message
  #3  
Old 02-04-2011, 04:37 AM
baracus baracus is offline
1st Gear
 
Join Date: Nov 2010
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Did you get the actual code or did the guy at Autozone just tell your mother which O2 sensor was needed? I ask because the downstream sensor on my Accord ('03 I4) went out last year and initially the guy told me that it was the upstream sensor. I double-checked based on the code when I got home and discovered that he was wrong. For me the CEL went off on its own after I changed the sensor.
Reply With Quote Quick reply to this message
  #4  
Old 02-04-2011, 08:05 AM
chiggaraccord03 chiggaraccord03 is offline
1st Gear
 
Join Date: Jan 2003
Posts: 29
Thanks: 1
Thanked 0 Times in 0 Posts
Agree. Make sure you change the correct o2 sensor. Autozone informed the o2 downstream sensor was bad. Brought Bosch OEM o2, installed it and CEL went off after the first start.
Reply With Quote Quick reply to this message
  #5  
Old 02-04-2011, 11:31 AM
nehonda's Avatar
nehonda nehonda is offline
6th Gear
 
Join Date: Sep 2007
Location: US Midwest
Posts: 1,632
Thanks: 2
Thanked 40 Times in 39 Posts
Just because you get an O2 sensor code doesn't necessarily mean the sensor is bad. You can have a rich or lean fuel conditions, exhaust leaks, shorted wires and other things causing the sensor to turn on the engine light. There are several diffrent O2 sensor codes that will help isolate the cause. You really need to troubleshoot the cause of the problem before throwing parts at it.
__________________
2000 Accord SE I4 F23A1 Auto - Sold @174k miles & 10 years ownership
1998 Accord LX I4 F23A1 5 speed - sons DD in DC
1987 Accord LX 5 spd Owned for 17 years sold @155k
1986 Accord LX Auto Totaled @137k miles
1983 Accord LX 5 spd My Second Accord traded in
1978 Accord LX 5 spd My First Accord sold @ 100k
Reply With Quote Quick reply to this message
  #6  
Old 02-04-2011, 04:11 PM
NightMarcher01's Avatar
NightMarcher01 NightMarcher01 is offline
aka 'The Gif King'
 
Join Date: Sep 2010
Posts: 803
Thanks: 0
Thanked 1 Time in 1 Post
First of all. Are you I4 or V6?

Second... why didn't the dude tell you the code? How can he just say o2 sensor? If you're I4, there's 2. And if you're V6, I believe there's 3.

They have different duties. So by him not telling you the code, you might have just spent money on something that you didn't have to change.

You should talk to the Manager.

Anyway, try disconnecting the battery. Wait 10 minutes, and connect it again. That should restart the computer. If the CEL is still on, then you just wasted your money!

This happened to me about 3 weeks ago... I even made a thread about it. The code was P0134
__________________
2003 Honda Accord Sedan

http://www.cardomain.com/ride/3877738

CHECK IT OUT!
Reply With Quote Quick reply to this message
  #7  
Old 02-04-2011, 06:32 PM
mobiless2's Avatar
mobiless2 mobiless2 is offline
mobiless2
 
Join Date: Sep 2009
Location: Florida
Posts: 1,611
Thanks: 9
Thanked 58 Times in 52 Posts
There is (4) O2 sensors on V6. 2 per side.
__________________
2005 SSM LX I-4 Auto Sedan: TL-S FSB / TL-S RSB / Tokico HTS Shocks / Neuspeed Sport Springs / 18" Element SC Wheels / 225-45-18 / TSX Rotors / CR-V Dual Piston Calipers / Drum to Disk Conversion / SS Brake Lines / K&N SRI / Japspeed TSX Header / TSX IM / P2R Thermal Gaskets / Ralco Pulleys / HFP Front Lip / OEM Deck Lid Spoiler / TSX Mirrors / OEM Fogs / HID Retro-Fit / K40 261K

2009 ASM EX I-4 Auto Sedan: Weapon-R I Throttle / TL FSB & RSB / Morimoto H1 / OEM Fog / K40 / Viper 5704 125K
Reply With Quote Quick reply to this message
  #8  
Old 02-05-2011, 02:13 AM
redbug2 redbug2 is offline
1st Gear
 
Join Date: Feb 2011
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Its a 4 cylinder.

My mother took the car to Autozone on my recomendation. I would hope that the guy reading the code would be smart enough to sell her the right sensor...(wishfull thinking),,,, Is the Cat sensor the same? If so, would be nice if I could swap the old front sensor provided the front one was good... Or, maybe they are both bad?
Reply With Quote Quick reply to this message
  #9  
Old 02-05-2011, 02:45 AM
NightMarcher01's Avatar
NightMarcher01 NightMarcher01 is offline
aka 'The Gif King'
 
Join Date: Sep 2010
Posts: 803
Thanks: 0
Thanked 1 Time in 1 Post
Quote:
Originally Posted by redbug2 View Post
Its a 4 cylinder.

My mother took the car to Autozone on my recomendation. I would hope that the guy reading the code would be smart enough to sell her the right sensor...(wishfull thinking),,,, Is the Cat sensor the same? If so, would be nice if I could swap the old front sensor provided the front one was good... Or, maybe they are both bad?
Nah bro... the I4 has two O2 sensors, Upstream sensor and Downstream sensor.

The Downstream sensor is on the Catalyic Converter, it serves no other purposes other than emission purposes.

The Upstream sensor 'aka' Primary sensor 'aka' Air/Fuel Ratio sensor is on the bottom of the exhaust manifold.

Did you try disconnecting the battery?
__________________
2003 Honda Accord Sedan

http://www.cardomain.com/ride/3877738

CHECK IT OUT!
Reply With Quote Quick reply to this message
  #10  
Old 02-05-2011, 04:00 AM
Drew03Accord Drew03Accord is offline
6th Gear
 
Join Date: Jul 2009
Location: Atlanta
Posts: 1,793
Thanks: 5
Thanked 52 Times in 44 Posts
Quote:
Originally Posted by redbug2 View Post
Its a 4 cylinder.

My mother took the car to Autozone on my recomendation. I would hope that the guy reading the code would be smart enough to sell her the right sensor...(wishfull thinking),,,, Is the Cat sensor the same? If so, would be nice if I could swap the old front sensor provided the front one was good... Or, maybe they are both bad?
The issue might be the sensor you bought. For one, you cant buy the OEM sensor at Autozone so the Bosch sensor is not OEM. Search around and you will see that some people have had immediate trouble using the Bosch sensor. When I changed mine years ago, I purchased it from a Honda dealer online. It was roughly $65 + ship. Wish I had the part number for u, but again, do a search.

Oh, and driving the car with the new sensor made the CEL disappear.
Reply With Quote Quick reply to this message
  #11  
Old 02-05-2011, 04:46 AM
drozzin drozzin is offline
5th Gear
 
Join Date: Mar 2009
Location: Hartford suburb, CT
Posts: 652
Thanks: 0
Thanked 11 Times in 9 Posts
How much does Bosch sensor cost? Is it upstream or downstream? AFAIK the only sensor that works reliably on Hondas is Denso.
__________________
Honda Accord hybrid '07
without NAVI Silver 198k miles - sold
Honda Accord Touring '13 MSM
Reply With Quote Quick reply to this message
  #12  
Old 02-05-2011, 06:06 AM
nehonda's Avatar
nehonda nehonda is offline
6th Gear
 
Join Date: Sep 2007
Location: US Midwest
Posts: 1,632
Thanks: 2
Thanked 40 Times in 39 Posts
The upstream and downstream sensors are different and not interchangable.
Always remember the parts store guys get paid to sell parts - not to diagnose your problems. And the parts they want to sell are the brand they carry - not always the best one for your car. If you are not well versed on modern car diagnostics they can really take advantage of you. As this sales guy aparently did.
If you kept your old O2 sensor, I would recommend putting it back in and try to get a refund on the Bosh sensor. Tell your story to the store manager if the counter guy baulks.
Car forums like Drive Accord are very useful to research problems before you go parts shopping - not after.
__________________
2000 Accord SE I4 F23A1 Auto - Sold @174k miles & 10 years ownership
1998 Accord LX I4 F23A1 5 speed - sons DD in DC
1987 Accord LX 5 spd Owned for 17 years sold @155k
1986 Accord LX Auto Totaled @137k miles
1983 Accord LX 5 spd My Second Accord traded in
1978 Accord LX 5 spd My First Accord sold @ 100k
Reply With Quote Quick reply to this message
  #13  
Old 02-05-2011, 09:40 AM
redbug2 redbug2 is offline
1st Gear
 
Join Date: Feb 2011
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mothers car is 20 miles away, will disconnect battery provided she can find her radio pin key. My father may have one of those reset computers. Blows me away that Bosch builds a product that us faulty? Still hoping that resetting the computer may solve it.

If it fails I will surely attempt to take it back.
Reply With Quote Quick reply to this message
  #14  
Old 02-05-2011, 10:26 AM
Accordriver's Avatar
Accordriver Accordriver is offline
6th Gear
 
Join Date: Mar 2008
Posts: 1,678
Thanks: 0
Thanked 2 Times in 1 Post
Bosch sells an OEM direct fit for most cars. It isn't so much that the sensors are faulty- just that they don't seem to function quite as well as the Honda OEM sensors in Honda cars (different specs, different tolerances etc.).
__________________
-03 Honda Accord EX V6
-Debadged-17mm sway bar-UR crank pulley-AEM CAI
Reply With Quote Quick reply to this message
  #15  
Old 02-05-2011, 10:33 AM
CYANiDE CYANiDE is offline
VTAKKKK
 
Join Date: Jun 2009
Location: NY
Posts: 1,714
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to CYANiDE
Denso makes the OEM sensor for our 7th gens I believe.
__________________
2006 Accord EX i4 Sedan - 5AT - Graphite Pearl - [89,0xx miles]
FF Type II Coilovers || Skunk2 Front Camber Arms || Ingalls Rear Camber Kit || Acura TL-S 27mm Front/20mm Rear Sway Bars || K&N SRI
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Drive Accord Honda Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
The answer to the random question may be found under the Off Topic section of the forums and in the "Drive Accord Forums" category.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 11:59 AM.




Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.