03-07 Spool Valve (VTEC Solenoid) Replacement *Help Needed* - Drive Accord Honda Forums

Go Back   Drive Accord Honda Forums > Honda Accord Main Forums > The 7th Generation

Drive Honda Accord Forums
Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 10-13-2012, 07:57 PM
MikeyThumbs MikeyThumbs is offline
4th Gear
 
Join Date: Mar 2012
Location: Long Island, NY
Posts: 323
Thanks: 12
Thanked 12 Times in 12 Posts
03-07 Spool Valve (VTEC Solenoid) Replacement *Help Needed*

Was wondering if anybody had any info on replacing the Spool Valve Assembly which houses the VTEC Solenoid on an 03-07 Accord.. I have the part already but I'm not sure if I am going to run into any issues when I jump into this. Can't seem to find any info or videos on a newer accord, only a youtube video for a 95 Accord. Any info would be greatly appreciated..
Attached Images
  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-16-2012, 07:25 AM
MikeyThumbs MikeyThumbs is offline
4th Gear
 
Join Date: Mar 2012
Location: Long Island, NY
Posts: 323
Thanks: 12
Thanked 12 Times in 12 Posts
Well I changed the valve this weekend, was a piece of cake!!
I removed the hood to make things easier for myself... had to put the new hood that I had on anyway so it worked out nicely.

The Spool Valve assembly replacement took me all of 25 minutes to complete start to finish.

Turns out there was a sliver of rubber gasket material in the strainer which I think was causing my problem and possibly why it only happened intermittently but time will tell..

I've only put about 35 miles on the new assembly so far, will let you know if I have any further issues
Reply With Quote Quick reply to this message
  #3  
Old 10-16-2012, 07:31 AM
sodaks2k sodaks2k is offline
Moderator
 
Join Date: Feb 2009
Location: Omaha, NE
Posts: 5,390
Thanks: 1
Thanked 14 Times in 13 Posts
Basically plug and play then? Good to hear it went well.
__________________
Filling a need-2006 Accord EX manual 5spd sedan
Reply With Quote Quick reply to this message
  #4  
Old 10-16-2012, 07:34 AM
MikeyThumbs MikeyThumbs is offline
4th Gear
 
Join Date: Mar 2012
Location: Long Island, NY
Posts: 323
Thanks: 12
Thanked 12 Times in 12 Posts
Yup, had a harder time getting the clips that hold the wires onto the valve assembly off then I did removing the actual part You cant really see whats going on back there, gotta kind of just feel for the bolt, get the socket on and loosen/tighten it blind. I used a regular 10MM deep socket and 3/8 ratchet with ease.. So much room back there compared to the video I saw on the 95 accord!!
Reply With Quote Quick reply to this message
  #5  
Old 10-16-2012, 09:23 AM
Coley909's Avatar
Coley909 Coley909 is offline
5th Gear
 
Join Date: Mar 2012
Location: North East PA
Posts: 631
Thanks: 0
Thanked 1 Time in 1 Post
What kind of problems where you having to need to replace this part?
__________________
07 Accord SE i4
kenwood 6.5 front
Sound ordinance 6x9 rear deck
Blitzsafe AUX input
18 inch wheels 245x45x18
Tint 20% rear 35% front
Parrot MKI9200
Reply With Quote Quick reply to this message
  #6  
Old 10-16-2012, 09:40 AM
MikeyThumbs MikeyThumbs is offline
4th Gear
 
Join Date: Mar 2012
Location: Long Island, NY
Posts: 323
Thanks: 12
Thanked 12 Times in 12 Posts
CEL was throwing code P2647: Rocker Arm Oil Pressure Switch (VTEC Oil Pressure Switch) Circuit High Voltage
The car would get to 2500-3000 RPM and under ANY type of gas applied would bog and shake violently almost like a rev limiter being hit at 3K rpm..

Did some research and since my oil was at a normal level, next step was replacing the vtec solenoid. Seemed easier and a little more sensible to replace the entire spool valve assembly which houses the solenoid. I could have just replaced the gasket, but the guy at the dealership told me that the VTEC solenoid was $80+ and the new entire spool valve assembly was $111. I wanted to see what the screen inside the old assembly looked like anyway so I just went for it.. Lucky for me that I did decide to replace the entire assembly though as I mentioned I found a big piece of gasket in there which I think was causing my issue.
Reply With Quote Quick reply to this message
  #7  
Old 10-16-2012, 10:36 AM
Coley909's Avatar
Coley909 Coley909 is offline
5th Gear
 
Join Date: Mar 2012
Location: North East PA
Posts: 631
Thanks: 0
Thanked 1 Time in 1 Post
Quote:
Originally Posted by MikeyThumbs View Post
CEL was throwing code P2647: Rocker Arm Oil Pressure Switch (VTEC Oil Pressure Switch) Circuit High Voltage
The car would get to 2500-3000 RPM and under ANY type of gas applied would bog and shake violently almost like a rev limiter being hit at 3K rpm..

Did some research and since my oil was at a normal level, next step was replacing the vtec solenoid. Seemed easier and a little more sensible to replace the entire spool valve assembly which houses the solenoid. I could have just replaced the gasket, but the guy at the dealership told me that the VTEC solenoid was $80+ and the new entire spool valve assembly was $111. I wanted to see what the screen inside the old assembly looked like anyway so I just went for it.. Lucky for me that I did decide to replace the entire assembly though as I mentioned I found a big piece of gasket in there which I think was causing my issue.

Ahh good to know incase it ever happens
__________________
07 Accord SE i4
kenwood 6.5 front
Sound ordinance 6x9 rear deck
Blitzsafe AUX input
18 inch wheels 245x45x18
Tint 20% rear 35% front
Parrot MKI9200
Reply With Quote Quick reply to this message
  #8  
Old 10-19-2012, 07:53 AM
MikeyThumbs MikeyThumbs is offline
4th Gear
 
Join Date: Mar 2012
Location: Long Island, NY
Posts: 323
Thanks: 12
Thanked 12 Times in 12 Posts
So far have about 100 miles on the new Spool Valve assembly with no issues ::knocks on wood.:: Next week is a heavy driving week for me, will put about 350+ on her.. I'll let you know how it goes.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Drive Accord Honda Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
The answer to the random question may be found under the Off Topic section of the forums and in the "Drive Accord Forums" category.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 03:24 PM.




Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.