Electrical Problems with '03 Accord - Drive Accord Honda Forums
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
post #1 of 6 Old 04-13-2019, 03:51 PM Thread Starter
1st Gear
 
CommuteDriver's Avatar
 
Join Date: Apr 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Electrical Problems with '03 Accord

Hi all. Recently my cars (2003 Honda Accord Coupe LX with a 2.4 cylinder engine) electronics have been acting up. I've attempted to make some minor fixes, and do some research on these issues, but at this point I'm stumped. At the moment I'm assuming all of these issues must be related to one another in some way, due to the timing of these malfunctions, but I'm more or less still learning about car maintenance, and I'm unsure if I'm missing something big.

1. My car windows don't work, at all
-From what I understand, typically a faulty window might be because of a power issue, or it could be because of the motor failing. However, I've ruled out a faulty motor because on the day I noticed my power window no longer worked, I was unable to operate any of the windows in the car from the driver side master switch. The window switches on each door have all been tested, and none of them work either. I'm extremely skeptical that all of the motors might have suddenly stopped working at the same time, so I'm ruling that out as a potential issue. All of the door locks still function normally, as do my mirror controls.

2. Speaker problems?
-The second electrical issue is that, while the radio and sound system seems to be getting power (it turns on and doesn't turn off randomly or anything), no sound comes through the car speakers. On a blue moon, occasionally I'll get sound to come through the speakers, but otherwise it's either dead silence or a harsh screech.

3. Overhead cabin light flickers
-After taking a look at the bulb inside the cabin light, it doesn't appear damaged in any way. Despite this, the light flickers repeatedly after it is turned on.

After doing some digging, I started thinking that the multiplexer in my car might be the issue, as I'd noticed other threads with drivers having similar power issues. However, trying to find details about a replacement master control unit on honda parts websites and the like haven't turned up any results. Am I on the right track here? Are all of these problems independent of each other, and I just happened to be unfortunate to have all of these issues crop up around the same time?

CommuteDriver is offline  
Advertisement
 
post #2 of 6 Old 04-13-2019, 04:31 PM
Roll Tide!
 
jimijam's Avatar
 
Join Date: Jan 2010
Location: In your head
Posts: 7,210
Thanks: 1,661
Thanked 1,076 Times in 823 Posts
Was this a flood car?


2007 V6 AT Sedan

Go! Fast! A little speed will make ya want a little more.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jimijam is offline  
post #3 of 6 Old 04-13-2019, 05:53 PM
1st Gear
 
Join Date: Feb 2019
Posts: 7
Thanks: 4
Thanked 0 Times in 0 Posts
My car only has the speaker problems and the overhead light doesnt turn on. Windows still work.

My solution to the speaker is to use my phone and Bluetooth speaker.

PS. Just want to follow this thread

2003 LX I4 Automatic 175k miles
Albert Yip is offline  
Advertisement
 
post #4 of 6 Old 04-13-2019, 06:59 PM
Out of Control
 
mtts60's Avatar
 
Join Date: Sep 2014
Location: Montana, USA
Posts: 3,035
Thanks: 42
Thanked 345 Times in 313 Posts
Garage
Quote:
Originally Posted by CommuteDriver View Post
3. Overhead cabin light flickers
-After taking a look at the bulb inside the cabin light, it doesn't appear damaged in any way. Despite this, the light flickers repeatedly after it is turned on.
Bad ground at the light. Pop the cover off and make sure the screws inside are tight and the ground loop(s) are clean. Could also be a corroded switch; easily fixed with some fine sandpaper.

Regarding the speaker and window problems, did they just start or has it always been this way?

2007 Accord SE sedan; I-4 automatic

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- my car's thread
mtts60 is online now  
post #5 of 6 Old 04-14-2019, 02:23 PM Thread Starter
1st Gear
 
CommuteDriver's Avatar
 
Join Date: Apr 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Thank you for the responses!

@jimijam: No water damage as far as I'm aware, and from the vehicle history report when I first got the car. I've tried to be as careful as possible not to let water leak into the car, but we do get some pretty heavy rainstorms around here, is it possible some of the wiring was damaged while I was opening the car door during a downpour?

@Albert Yip: I did have Bluetooth functionality installed into the car which was handled by Best Buy a few years back. Worked great up until I randomly started to have issues with the sound. Any recommendations for a portable speaker?

@mtts60: I'll be sure to take a look at the ground just to make sure it's all clear, thanks! The speakers started to malfunction around a year ago. I elected not to make too much of a fuss about it because of the timing, college classes being in full swing and papers being the biggest concern at the time. I mostly just relied on the speakers in my phone. The windows are more recent, and I would say they started having problems around the end of winter, about the first week of January?
CommuteDriver is offline  
post #6 of 6 Old 04-14-2019, 06:27 PM
Out of Control
 
greg1c's Avatar
 
Join Date: Aug 2013
Location: Hotlanta
Posts: 3,403
Thanks: 34
Thanked 554 Times in 481 Posts
My guess is the master window switch, they can get water in them and stop working. You can get them on eBay or Amazon for about $35. The radio is most likely bad connections. I would pull it out and verify everything is connected with solid connections. The light is most likely a loose ground. Do all doors cause the issue?? Do it work normally when you turn it on.

Anker makes a great Bluetooth speaker, you could use that temporarily till you get the radio working properly.

Sent from my Pixel 2 using Tapatalk

Current Honda vehicles
2010 Acura RDX Turbo AWD/Tech 67k miles - Daily Driver
2013 Accord EX-L I4 Auto 53k miles Black Pearl - Wife's car
2005 Acura TSX Auto 208k miles - Youngest Daughter
2013 FIT Sport Auto - 24k miles - Oldest Daughters car
Former Honda Vehicles
2001 Acura MDX Totaled t223k
1991 Accord LX auto sold 185k miles
1995 GSR sold @220k miles
1991 Civic SI Crushed by a tree during a tornado 1997
1989 Prelude SI soldr @44k miles
1986 Civic 5 speed sold @165k miles
greg1c is offline  
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Drive Accord Honda Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
The answer to the random question may be found under the Off Topic section of the forums and in the "Drive Accord Forums" category.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical Problems with '03 Accord Coupe-Help? spoonch The 7th Generation 2 03-04-2012 11:08 PM
2004 Honda Accord Electrical Problems Pants116 The 7th Generation 2 10-24-2011 02:24 AM
Few Electrical Problems with 04 Accord RayneMayne The 7th Generation 5 02-21-2011 11:20 PM
Electrical problems 2004 Honda Accord Tourer 2.4 Baselbyt Problems & Solutions 1 06-24-2010 05:06 PM
electrical problems with 1997 accord biglug Problems & Solutions 3 01-21-2009 06:30 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome