Drive Accord Honda Forums banner
1 - 20 of 23 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
So the issue is that sometimes the car does not start. it cranks good, but wont start. I can hear that when turning on the ingnition, the fuel pump runs for a second, and then stops. In normal situation the fuel pump runs for several seconds, and then when trying to start, it will start fine.
After the car starts, it runs normal.

I hav been looking to find anything about this issue from the internet and found couple of forum posts, with the exact description, but none of these posts have anything about the sollutions.
I have read, that on older models, there was an issue with the main relay, that caused these symptoms, but this car does not have the main relay anymore.

2.nd question: I thought that I maybe get another ECU from the junkjard. But how different are these? If I get another one for a Gen7 2.0 will this be ok to be installed, or are there more variations, that I should know about?
And would the replacement of ECU cause any other complications?

also, as I mentioned, the fuel pump turns on for a second, but also I can hear some relay clicking once af the fuel pump shuts off. The click sound from the middle ot the centre console.
 

·
Registered
Joined
·
5,236 Posts
also, as I mentioned, the fuel pump turns on for a second, but also I can hear some relay clicking once af the fuel pump shuts off. The click sound from the middle ot the centre console.
The 2006 European accord was sold in the USA as an Acura. Maybe a starter problem also (?).
 

·
Registered
Joined
·
5,171 Posts
I seriously doubt you have an ECU issue.

Are there any codes in the ECU?

How many miles/kilometers does this engine have on it? I assume this is a gasoline fueled engine. When was the last time the spark plugs where replaced?

Sent from my Pixel 5 using Tapatalk
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #4 ·
i dont think it´s starter or plugs issue.Im pretty sure the engine is not getting fuel. Something is cutting the fuel pump.
Starter is cranking good and when it starts, it also runs good.
 

·
Registered
Joined
·
5,236 Posts
ill try that.
is there anything special about this blue relay? or could any other(cheap) relay with this functionality be used?
Are you asking if you have to get an oem part replacement or if a generic replacement relay will work ? Oem "Will" work, a generic part "May" work. Anything electrical I always use a oem part (except a car battery).
 
  • Like
Reactions: Yal

·
Registered
Joined
·
5,171 Posts
If temperature change does different things, I would suspect the IAT or ECT not reading correctly.

You can read those values when it is cold and verify those temperature readings need to be correct.

Sent from my Pixel 5 using Tapatalk
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #11 ·
Its not the starter. As i described earlier, something is cutting the fuel pump. Its possible to hear something clicking and the fuelpump buzzing stops.
I think the temperature change could mean that some bad contact expand and contract, and this is causing an error somewhere. Or there is some condensation cathering somewhere and shorting something.

I have seen this same issue described in forums before, but these threads always end before there is any discussion, how this was solved.
 

·
Registered
Joined
·
280 Posts
The fuel pump runs long enough to get the fuel pressure up then stops making noise. The threads end because they got new starters and solved the problem. Just sayin'
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #14 ·
You`re not wrong. But the pump is not running long enough. If usually it runs for , lets say 2seconds to get the pressure up, then in tha cases where its not going to start, it runs for 1 second, and there is a distinct relay click that stops the pump.
 

·
Registered
Joined
·
280 Posts
"the fuel pump turns on for a second" Sure I read it, but took it out of context. Most times when some says "a second" they don't literally mean 1 second. They are referring to a short interval of time. Me: Are we leaving soon. Wife: In a second. (Translation - any random amount of time).
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #18 ·
sure. But if this "a second" is compared with an amount of time described as "several seconds ", then it might as well be meant as 1 second.

But jeahh.. I cant really give any suggestions eighter, how You could fix this wife issue.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #19 ·
Unfortunatelly since the car wont give any fault codes(check engile light) while not sarting, mechanics dont really want to deal with this car.
Im probably just need to start replacing parts, hoping for good luck. I have read something about that failing crankshaft sensor might do something similar. So probably start with this. although, it shoult give a code, if this one is failing.
 

·
Registered
Joined
·
2,554 Posts
YouTube may point you in the right direction with trouble shooting steps. Look up channels like pine hollow auto diagnostics , south main auto, diagnose dan and many other reputable channels. There are also many russian speaking channels that show and describe the logic process of troubleshooting no start issues.

Some are as simple as in need of OEM crank sensor or rubbed through insulation wire shorting out, or corrosion.

Take your time to approach on a logical manner to the task. After all you need compression, spark and fuel. Verify which one is missing and go for it.

Look online as there are places like eBay sells service manuals, or you may find one to download for free online.
 
1 - 20 of 23 Posts
Top