Drive Accord Honda Forums banner
1 - 3 of 3 Posts

· Registered
Joined
·
4 Posts
Hello Accord Fam,

I bought a salvage 2008 Honda Accord 3 years ago and since California has been in a drought there hasn't been much rain. Long story short, my wipers stop working at random times when driving in the rain. Sometimes for a few seconds, minutes and one time for a few days. Also, the A/C would stop working as well.

Have anyone experienced this problem? Any ideas on what can it be? This winter has been very Wet in California and need to get this fixed soon.

+

I replaced the power steering pump about 1 year ago because it was leaking at the shop but I never really checked on it because I trusted the work and never noticed it. But now 1 year later I noticed that it is leaving again. I am going to bring back to the shop because it does have warranty.

Also, in the picture the fluid is getting onto the alternator. any advice?

I just wanted to ask the forum on maybe why is it leaking again? What should I say when I bring it into the shop?

Thank you so much for your help,

Please see photos attached.
 

Attachments

· 2020 best year
Joined
·
4,410 Posts
Rule #1 when buying cars: don't buy a salvage... unless you really know what you are doing. It's just endless pain.

Anyways, for the wipers, I think it could either be the wiring or the motors. You could be having some bad contacts with the wiring. Hard to say. With salvage cars, anything can happen.

The AC is driven by the drive belt, so you should check the unit to see if that's working. Not 100% sure about the troubleshooting procedures.

The power steering pump shouldn't be leaking easily. I detached a bunch of hoses before on my car for flushing and reconnected them. The pump still doesn't leak. Did you check the hose clamps to see if they are clamping down?

For the alternator, is there anything weird going on electrically in your car?
 

· Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
The only thing weird going on with my car is the windshield wipers/A/C/ Radio going on and off during the rain.

The spot that looks to be leaking the 1st photo the top left area where there is a gap and it seems to be oily. I stuck my finger in between and there was oil.

Thank you,
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top