Drive Accord Honda Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1 (Edited)
First Post so, Please, be kind :paranoid:

I have a 2009 V6 Sedan with Nav and Premium sound system. Before I found this great forum, I ordered a PXAMG with install kit. I found out how to install it on this forum (I can now "field strip" the system in under 30 minutes :biggrin:). After wading thru 20 plus pages of posts (good posts) and finally going to the vendor's site, I find that the PXAMG is NOT compatible with the NAV system (It appears that nothing is compatible with it) :lmao:

Anyway, I know that the Honda Ipod adapter doesn't work (Thanks Collegehills Honda for the great research, I only wish you were close to me).

Has anyone come up with any way to integrate the Ipod into the 2009 with nav? Or, Am I forever stuck with the crummy aux in mode? The PXAMG some times works but I lose my SAT reception so it's history for me.

OBTW I now have a PXAMG with harness kit for sale:lmao:

Thanks, in advance!

Cheers,

Dave
 

·
2016 Nissan Maxima Platnm
Joined
·
4,574 Posts
I have no idea where you got your information, but the PXAMG (now known as the iSimple) is 100% compatible with the 09 Accord with Nav. Here is their YouTube video showing the operation in the Accord with Nav

http://www.youtube.com/watch?v=6Am-h--xyJI

Check the vendor's website and make sure you have the latest firmware installed. If it still doesn't work, contact them for support because you might be installing it wrong or have a unit that needs to be replaced.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
I have no idea where you got your information, but the PXAMG (now known as the iSimple) is 100% compatible with the 09 Accord with Nav. Here is their YouTube video showing the operation in the Accord with Nav

http://www.youtube.com/watch?v=6Am-h--xyJI

Check the vendor's website and make sure you have the latest firmware installed. If it still doesn't work, contact them for support because you might be installing it wrong or have a unit that needs to be replaced.
Thanks for the link. That is exactly what I have in my dash. I think my "confusion" stems from the fact that now a place called PAC-Audio comes up when I try to access Peripheral Products (iSimple???). My unit is labelled Peripheral PXAMG, so, I assume that the unit remains the same. I just upgraded the firmware from .36 to 778b and it didn't complain. I bought the unit just after I bought the car (March 2009) and I had to get a hip replaced so I just got around to installing it. I sure hope the firmware upgrade fixes the issues.

Thanks, again. And I'll post the results of the upgrade. This forum is great! :thmsup:

Dave
 

·
Registered
Joined
·
7 Posts
I have no idea where you got your information, but the PXAMG (now known as the iSimple) is 100% compatible with the 09 Accord with Nav. Here is their YouTube video showing the operation in the Accord with Nav

http://www.youtube.com/watch?v=6Am-h--xyJI

Check the vendor's website and make sure you have the latest firmware installed. If it still doesn't work, contact them for support because you might be installing it wrong or have a unit that needs to be replaced.
That video seems confusing and the bottom half of the screen seems pretty useless according to the video. The honda usb interface on the new 11 models works much better imo
 

·
Registered
Joined
·
2,953 Posts
That video seems confusing and the bottom half of the screen seems pretty useless according to the video. The honda usb interface on the new 11 models works much better imo
But the Honda USB adapter doesn't work on '08 or '09 Accords or on ones with navi.
 

·
2016 Nissan Maxima Platnm
Joined
·
4,574 Posts
Thanks for the link. That is exactly what I have in my dash. I think my "confusion" stems from the fact that now a place called PAC-Audio comes up when I try to access Peripheral Products (iSimple???). My unit is labelled Peripheral PXAMG, so, I assume that the unit remains the same. I just upgraded the firmware from .36 to 778b and it didn't complain. I bought the unit just after I bought the car (March 2009) and I had to get a hip replaced so I just got around to installing it. I sure hope the firmware upgrade fixes the issues.

Thanks, again. And I'll post the results of the upgrade. This forum is great! :thmsup:

Dave
PAC-Audio bought out Peripheral, so they changed the name from PXAMG to iSimple. The devices are the same, as you were able to successfully update the firmware. Big jump in the firmware version! Hopefully that fixes the problem, if not, PAC-Audio should provide you with support since they now sell the product.
 
1 - 7 of 7 Posts
Top