Drive Accord Honda Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I replaced the speedometer in my 96 Accord, as the old one was jumping to 20 mph and sticking there. I purchased a used one that was working when they took it out of the other car. Now, in my car, it works sometimes but not consistently. This one will sit on 0 mph and then just jump up to whatever speed I'm going. It seems to work better when the car is hot - like it's been sitting in the sun. Then sometimes, after it is working, it's just stop and drop back to 0. Any ideas?
 

·
HS4LYF!!
Joined
·
8 Posts
I replaced the speedometer in my 96 Accord, as the old one was jumping to 20 mph and sticking there. I purchased a used one that was working when they took it out of the other car. Now, in my car, it works sometimes but not consistently. This one will sit on 0 mph and then just jump up to whatever speed I'm going. It seems to work better when the car is hot - like it's been sitting in the sun. Then sometimes, after it is working, it's just stop and drop back to 0. Any ideas?
It sounds like your VSS (Vehicle Speed Sensor) is going bad, try replacing that instead. That usually affects the spedometer.
 

·
Registered
Joined
·
154 Posts
Im with hahakenny. Vss sounds bad. the gear is probably worn and is slipping on the diff.
 

·
Moderator
Joined
·
1,927 Posts
Could be the VSS, but . . .

My '94 Accord LX had the exact same behavior at 200,000 miles almost on the nose. I estimated miles by tanks of gas until I took it to the dealer who diagnosed a bad speedometer head and replaced it. At 8,000 miles on the new head, IT failed in exactly the same way. Dealer replaced under warranty. So it's not far-fetched to me that your used speedo head could also go bad.
 
1 - 6 of 6 Posts
Top