Drive Accord Honda Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1 (Edited)
Hi guys! 2009 accord sedan LX with 200k. My VSA and ABS lights will just decide to turn on and off as they choose (and this includes the actual functionality of the ABS/VSA).

Basically, if I start my car, there's a 50% chance the lights are on, and a 50% chance the lights are off. My guess would be this is a connection issue, but have any of you guys had this experience before?

Any input on diagnosing and fixing this would be appreciated!

(UPDATE: Fixed the issue by replacing the rear right ABS sensor, was a $50 part)




518140
518141
518142
 

·
Registered
Joined
·
14 Posts
Take it to an Auto Parts store with a scanner that will check Honda Codes. Sounds like the ABS modulator could be going bad. I am sure the check engine light will be on soon. The problem is with ABS and if that is off then the VSA disables by default as the two work hand in hand.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
Take it to an Auto Parts store with a scanner that will check Honda Codes. Sounds like the ABS modulator could be going bad. I am sure the check engine light will be on soon. The problem is with ABS and if that is off then the VSA disables by default as the two work hand in hand.
The images in the OP are from a few weeks ago, I've scanned for CEL's myself since then and nothing threw.

Does an auto place have a honda specific code reader that can read more in depth than the $20 amazon bluetooth ones?
 

·
8th Gen Believer
Joined
·
3,782 Posts
AutoZone has them, they'll scan for free but it's always nice to tip the guy.
 

·
Registered
Joined
·
4,040 Posts
Do not confuse OBDII and SRS/ABS codes. You need a scanner capable of reading the ABS codes. We would all be guessing what could be happening without the codes.

Sent from my Pixel 2 using Tapatalk
 

·
Registered
Joined
·
733 Posts
Did you had a brake job done recently?
 

·
Registered
Joined
·
4,040 Posts
It would appear you have a bad right rear sensor. Did you get them all cleared?

Sent from my Pixel 2 using Tapatalk
 

·
Registered
Joined
·
6 Posts
Did you changed yourself? Oem or aftermarket part? Can you send a link from where you bought? Have some photos of the repair? Hard? Easy?
So many questions... thanks!


Enviado do meu iPhone usando Tapatalk
 
1 - 15 of 15 Posts
Top