Drive Accord Honda Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hello everyone,
As some people know, there is a problem with Android Auto and Google Maps on the touring trim of the Accord. Some kind of incompatibility between android auto and the embedded car GPS or the head up display that does not allow Google Maps to navigate to a destination. I brought the car for service and complained about the issue, and now they are telling me the head unit needs to be replaced. I am afraid that will bring more problems than solution. I would hate if after doing that the dash starts making noise, or something else stops working properly. What do you guys think about that?
 

·
Registered
Joined
·
871 Posts
I think you should let them repair the issue, or live with it. I'm not sure what input you're looking for.

As a data point, I use Android Auto every day, including Google Maps, and have never had an issue with navigation. My car is a 2018 Touring.
 

·
Registered
Joined
·
68 Posts
2019 Touring - no issues either. Only "issue" is that the directional arrows are white rather than blue. What Android device and version are you running?

---

Update. Well poop - Google Maps on Android Auto Not Working?, didn't know that was going on. I have an Note 10 Plus, just unloaded a Pixel 3 - didn't have issues with either.

Totally get your concern about swapping it out, short of resetting everything to factory on the phone and Accord, then trying again - replacement sounds like the only real solution.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
Wow, based on this Google forum post I thought everybody with a touring had this issue. It is good to know that not everybody has the problem. I was afraid they would replace the unit and the problem would persist. According to the Google moderator Honda was supposed to release a firmware update to fix it but they haven't released it so far. My phone is a Pixel 3 XL running Android 10.
 

·
Registered
Joined
·
97 Posts
I use my AA with google maps everyday and don't have any issue. (knocks on wood).

You could try a few things before replacing it.

As mentioned, factory reset the head unit.

With that, you can clear the app data /cache for Google maps on your phone.

Clear the phones entire cache by entering download mode (no phone data is lost).

Revert to previous working version of Google maps and or Android auto. (apkmirror. Com)

Completely wipe your phone.

Make sure you are using your oem cable.

Enter diagnostic mode and check for any errors (google/youtube for directions, super easy).

Hopefully something there helps, I too wouldn't want them pulling apart my dash. These headunits are definitely the weak link in these vehicles.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #8
Did you try re-booting the system in the car?

Procedure.
Didn't work.

I use my AA with google maps everyday and don't have any issue. (knocks on wood).

You could try a few things before replacing it.

As mentioned, factory reset the head unit.

With that, you can clear the app data /cache for Google maps on your phone.

Clear the phones entire cache by entering download mode (no phone data is lost).

Revert to previous working version of Google maps and or Android auto. (apkmirror. Com)

Completely wipe your phone.

Make sure you are using your oem cable.

Enter diagnostic mode and check for any errors (google/youtube for directions, super easy).

Hopefully something there helps, I too wouldn't want them pulling apart my dash. These headunits are definitely the weak link in these vehicles.
I already tried all this and it did not work. Do you also have a touring trim? This issue affects only the touring.
 

·
Registered
Joined
·
1,118 Posts
Did you show that Google posting to the dealer?

Perhaps contact Honda Canada?

In the meantime have you tried Waze or another map program? Do they work?

(Or, do the rational thing and get an iPhone. A lot of used iPhone 7's/8's coming on the market.)
 

·
Registered
Joined
·
15 Posts
Discussion Starter #11
Did you show that Google posting to the dealer?

Perhaps contact Honda Canada?

In the meantime have you tried Waze or another map program? Do they work?

(Or, do the rational thing and get an iPhone. A lot of used iPhone 7's/8's coming on the market.)
I already contacted Honda Canada and they asked me to bring the car to the dealership.

Waze works but not on the first try. It cancels the navigation the first couple of times and then it starts but becomes very laggy. Today I tested an older version of Waze and it worked fine, which shows Google is also to blame.

I cannot see myself switching to an iPhone right now. And I know car play also has its fair share of problems.
 

·
Registered
Joined
·
1,118 Posts
^I have nearly 0 issues with CarPlay other than random restarts every 1 - 2 months. That's annoying, esp. when it happens just when you really don't need that to happen.

I don't have that trim and recognize that there may be something in that, but as you said earlier a Google contact has said that Honda have rolled out a fix. Take that Google message to the dealership.

Did Honda Canada at least confirm there is a fix?

Otherwise sounds like they're brushing you off to the dealership. Since Honda Canada will likely have done diddly squat with cherry sauce in contacting your dealer, the dealer will just be mystified unless a miracle has ensued. (There is hope after all).

If all this fails I suggest a registered letter to:
  • Honda Canada
  • Your dealership
Detailing:
1. The Google message saying there is a fix from Honda.
2. The dealership's ineptitude.
3. Honda Canada's lack of cooperation in just bouncing you back to the dealership.
4. The dealership's continued ineptitude.
5. Threat. (Up to you: lawyer, consumer protection, yadaua....).

Do all this as fricken politely as possible. It's more fun that way.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #13
Today I brought the car to the dealer to have the head unit replaced, and I am happy to report that that solved the issue. I recommend everyone with this problem to do the same instead of waiting for Honda to issue a software update. Attached is the service bulletin. Thank you everyone that contributed with their experience with the car!
 

Attachments

·
Registered
Joined
·
4 Posts
I've recently been having issues w/AA on my 2019 Touring as well. Had it connected one morning on my way to work, stopped to get gas, and could never detect my phone after that.

Going to try some of the suggestions above such as a factory reset. Been meaning to another Android phone to make sure it's just not my phone. I have the OnePlus 7t which has worked great since November up until a few weeks ago. I hate driving w/o AA!! I heavily depend on Waze...
 
1 - 15 of 15 Posts
Top