Drive Accord Honda Forums banner
1 - 14 of 14 Posts

·
Registered
Honda Accord 2006 EX-L Nav. 2.4l with 123K miles
Joined
·
123 Posts
Discussion Starter · #1 ·
When I was driving to work, I turned off my A/C for a while like 10 minutes or so, then I got a battery light on (the A/C may be completely unrelated but worth mentioning it), I turned everything off and the car drove fine but I could hear a soft whine noise. After I parked and opened the hood found some smoke coming from the alternator area. Turned the car off and the smoke went away, I checked the belt and it loosk fine.

Turned the car on and no problem to start, then the smoke came out again from the same area.

Is my Alternator gone? Can I attempt to drive home (30 minute stop and go drive)?

Thanks in advance.
 

·
Super Moderator
Joined
·
3,482 Posts
Pull the belt off and see if the smoke is still coming. I wouldn't drive 30 minutes with smoke coming from the engine especially if it's from an electrical component.
 

·
Registered
Joined
·
4,883 Posts
Smoke from the alternator is not a good sign. Is there something leaking into the alternator, coolant, oil, power steering fluid?

I would not drive with a smoking alternator until I figured bout the cause. It is either something leaking into the alternator or an issue with the alternator.


Has this alternator ever been replaced and how many miles and is this a V6 or 4 cyl.

Sent from my Pixel 5 using Tapatalk
 

·
Registered
Honda Accord 2006 EX-L Nav. 2.4l with 123K miles
Joined
·
123 Posts
Discussion Starter · #4 ·
Smoke from the alternator is not a good sign. Is there something leaking into the alternator, coolant, oil, power steering fluid?

I would not drive with a smoking alternator until I figured bout the cause. It is either something leaking into the alternator or an issue with the alternator.


Has this alternator ever been replaced and how many miles and is this a V6 or 4 cyl.

Sent from my Pixel 5 using Tapatalk
There was an oil leak and PS leak that I fixed about a month ago. The Alternator still looks greasy from that and I didn't know how to clean it so I left it that way. There's also a coolant leak (losing coolant from the reservoir and finding a few drops on the floor) that I haven't been able to track, but I don't think there's anywhere that the coolant can drop onto the alternator or am I wrong?

Its an i4 with 126k miles on the original alternator.
 

·
8th Gen Believer
Joined
·
4,270 Posts
Sorry to hear this Diodio26. I'd just look for a path that coolant fluid leak could follow to the alternator.
 

·
Registered
Joined
·
42 Posts
battery light indicates possible alternator malfunction

I had a top sensor oil leak on my odyssey, which leaked oil all over the alternator, causing the alternator to die a month later
 

·
Registered
Honda Accord 2006 EX-L Nav. 2.4l with 123K miles
Joined
·
123 Posts
Discussion Starter · #8 ·
The a/c compressor is directly below the alternator. Maybe the alt is fine and the a/c clutch just smoked.
The A/C works fine. The smoke came with the A/C off. Can a bad A/C clutch turn a battery light on?
 

·
Super Moderator
Joined
·
6,655 Posts
Seized or hard to turn alternator pulley. That's why the soft whine.
 

·
Registered
Honda Accord 2006 EX-L Nav. 2.4l with 123K miles
Joined
·
123 Posts
Discussion Starter · #10 ·
Seized or hard to turn alternator pulley. That's why the soft whine.
Can the pulley be fixed or I need a new/used alternator?

With 126k miles will it be worth to fix it?
 

·
Registered
Joined
·
4,457 Posts
Have your alternator rebuilt or get a used one from a salvage yard.
 

·
Registered
Joined
·
4,883 Posts
First choice
If you have an auto electric business near you, remove your alternator and take it to them and let them rebuild it.

Second choice
Find a used one with low miles

Third choice buy a new Denso alternator

Fourth Choice buy a remanufactured Denso alternator.

Last choice a rebuilt alternator from a big box parts store with a "lifetime" warranty.


Sent from my Pixel 5 using Tapatalk
 

·
Registered
Honda Accord 2006 EX-L Nav. 2.4l with 123K miles
Joined
·
123 Posts
Discussion Starter · #13 ·
I turned on the car for like 2 minutes to test the battery. Touched the alternator and it was HOT, the engine and everything else was cold.

Removed the alternator and the pulley can rotate freely with no problem. Took it to a near workshop and they told me the something with the "diode" needs to be replaced, my other option was a used denso alternator from a junkyard with god knows how many miles. So I opted for the repair.

Will update with the result.
 

·
Registered
Honda Accord 2006 EX-L Nav. 2.4l with 123K miles
Joined
·
123 Posts
Discussion Starter · #14 ·
Done. They replaced this part.

Bicycle part Automotive tire Rim Circle Bicycle drivetrain part


No battery light. Rough idle at first, but I assume its because I need an idle relearn. Thanks to everyone who gave their opinions.
 
1 - 14 of 14 Posts
Top