Drive Accord Honda Forums banner

1 - 20 of 20 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Hi everyone

Wanted to make an introduction. I just bought a 2004 accord ex-l for the family. It replaced my wife's 2005 vw passat awd car in hopes of better mpgs and better reliability. My wife drives a lot for work and wanted something cheap and reliable.

I have a few issues I'd like to address:

1. At around 60-65 I get a slight shake on the highway, thinking it could need a wheel balance but is there anything else I could check? I.e. Cv axle?

2. I've have the srs problem which I've actually done so e research on, seems like it's either faulty seat belt or weight sensor, seems to be common.

3. The heat doesn't blow as hot as I think it should and the middle driver side vent blows colder then the rest of the three. Maybe a flush would help.

4. Last but not least, the Catalytic converter was replaced to fix the p0420 code but has come back on.

Overall I'm real happy with it, for 210k this thing runs like a top. If I could get these few things buttoned up it would be even better.

Thanks in advance
 

·
2nd Deer
Joined
·
334 Posts
1. slight shake at that speed could be a CV axle. I have the same problem, but have yet to get around to fixing it.
 

·
Registered
Joined
·
840 Posts
Google each problem with the year and model of car

As for the vibration - if it happens only under load, good chance its a bad CV axle (personal experience with this problem)
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #5 ·
I think I'm going to do a flush, I actually have a homemade "tool" to flush a heater core so once it's not -15 out I'll try that and go from there
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #6 ·
a little update, i replaced the cv axle and the car runs smooth as ever.

Ended up that the valve for the heater core cable broke so the was stuck shut for the most part, i just manually put that valve all the way open.

New problem that im trying to figure out is the cruise control, the cruise main comes on and i get to set and it doesnt set. The light comes on as if it was working but nothing. I checked the cable and the "plastic" piece on the throttle body and everything looks in working order. Im just not sure in which direction to go in now.
 

·
Registered
Joined
·
12 Posts
Cool little tip

Press the the unlock twice on the key fob and hold down on it the second time. It rolls down the windows. It will really help, especially since summer is coming. :thmsup:
 

·
Registered
Joined
·
4,742 Posts
1. At around 60-65 I get a slight shake on the highway, thinking it could need a wheel balance but is there anything else I could check? I.e. Cv axle?

Most likely wheel balance. Could also be a warped tire or bent wheel. You can try rotating wheels to see how things change as you move them around. At the very least you'll pinpoint whether it's wheel/tire related. If you take off a wheel, roll it on flat concrete and it has a wobble.... well.....

2. I've have the srs problem which I've actually done so e research on, seems like it's either faulty seat belt or weight sensor, seems to be common.

Seat belt buckles and belts are lifetime warranty from dealer. There might also be a recall on the buckle. Dealer fixed mine for free. Take your car to dealer and ask them to check all recalls on it. They will tell you what was done, or not.

3. The heat doesn't blow as hot as I think it should and the middle driver side vent blows colder then the rest of the three. Maybe a flush would help.

Check your cabin air filter which is accessed by dropping the glove door down. If clogged, it stifles air flow. Research how to back flush heater core. Finally, run a cooling system flush through your radiator with your heat set to hot (opens flow thru heater core) - sold at any auto parts. You probably need to replace coolant anyway. When you do, idle car with radiator cap off for 20 min to bleed any air. Air pockets can kill engine without triggering temp gauge.

4. Last but not least, the Catalytic converter was replaced to fix the p0420 code but has come back on.

Cheap cats don't work for long, if that is what you got. Better off buying used from low mileage crashed vehicle if you can find it.
 

·
Registered
Joined
·
804 Posts
a little update, i replaced the cv axle and the car runs smooth as ever.

Ended up that the valve for the heater core cable broke so the was stuck shut for the most part, i just manually put that valve all the way open.

New problem that im trying to figure out is the cruise control, the cruise main comes on and i get to set and it doesnt set. The light comes on as if it was working but nothing. I checked the cable and the "plastic" piece on the throttle body and everything looks in working order. Im just not sure in which direction to go in now.

i was wondering which axle did you replace? which side? i have that vibration as well.. its been making me nuts.. i got new tires.. and had sears RE-balance the wheels and still there...
 

·
03-SSM-AV6-6MT
Joined
·
830 Posts
^^^^ Check the compliance bushings.
 

·
Registered
Joined
·
128 Posts
Congrats on your buy, leather interior :thmsup:... From first hand account, not a good idea to get aftermarket cat. Invest on new Honda parts or like me, I just ordered an OEM cat from a low mileage accord off ebay for a 1/3 of the price same as aftermarket price.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #13 ·
the previous owner did the car, honestly i havent gone under to look if its oem or not. It sure doesnt feel like a clogged cat.

arkainzeye- i replaced the driver side cv axle.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #14 ·
as far as the cruise control i checked if the horn and brake lights work and they do, could it be the module? seems like thats all there is left
 

·
khol
Joined
·
106 Posts
Before you go out and buy a new cat converter try using one of those fuel cleaners first. My last car an '03 Camry LE had an engine light come on with regards to the converter. After using one of the fuel cleaners the problem when away.
 

·
khol
Joined
·
106 Posts
I have cataclean in it now, I have my fingers crossed hoping that will be it.
From my two experiences in the past (my '03 Camry and an '01 Highlander) the light went away around the half way point on the fuel gauge. Hopefully it will do the same for you :thmsup:.
 

·
girls are handy too...
Joined
·
25 Posts
i habe cataclean in it now, i have my fingers crossed hoping that will be it.
How did that Cataclean work for you? Was thinking about using it.
 
1 - 20 of 20 Posts
Top