Drive Accord Honda Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey everyone I just wanted to know what’s up with the charging system problem that prompted me on my 2019 accord it has 19k miles and I have a feeling it’s the battery and I hope it’s not the alternator. I called Honda and like always they want to charge 150 for a diagnostics so if any of you know how to fix it please throw me in the right direction thanks
 

·
8th Gen Believer
Joined
·
4,240 Posts
For $40 you can get a Konnwei KW600 battery tester from Amazon. Measures everything including CCA. Charges with USB.
 

·
Registered
Joined
·
35 Posts
The car should fall under basic warranty. They will always threaten the diag charge if not covered under warranty but if it needs a battery and you buy one they should not charge a diag fee and if it is an actual charging system issue it should be a covered repair. I'd let them check it. Or try a battery on your own and see what happens
 

·
Registered
Joined
·
1,329 Posts
Hey everyone I just wanted to know what’s up with the charging system problem that prompted me on my 2019 accord it has 19k miles and I have a feeling it’s the battery and I hope it’s not the alternator. I called Honda and like always they want to charge 150 for a diagnostics so if any of you know how to fix it please throw me in the right direction thanks
You're in warranty so should be no charge at all to investigate and remedy it.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Hey everyone I just wanted to know what’s up with the charging system problem that prompted me on my 2019 accord it has 19k miles and I have a feeling it’s the battery and I hope it’s not the alternator. I called Honda and like always they want to charge 150 for a diagnostics so if any of you know how to fix it please throw me in the right direction thanks
Update I took it to the dealer and they said it was a bad battery & the fuse for the horn was blown thanks for the reply guys
 

·
Registered
Joined
·
1,329 Posts
Update I took it to the dealer and they said it was a bad battery & the fuse for the horn was blown thanks for the reply guys
Did they charge you?
 
1 - 8 of 8 Posts
Top