Drive Accord Honda Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I NEED HELP!!!

My Honda factory installed navigation stopped working on me. It said that there was an disc read error message and for me to consult my dealer. It only works for the first 2-3 minutes when the car is first turned on and then gives me that error message.

I bought the new update disc a few months back and installed the upgrade just as instructed and now this happens.

I went to a Honda dealership yesterday and they took a look at it and said that there is a software problem with my navi. They would need to send it down to a third party to take a look at it which would cost me $150 and repairs could range anywhere between $650-800. (I no longer have warranty and I passed the time to get extended warranty smh)

Does anyone have any advice on other ways I can get this fixed??!!! PLEASE HELP!!!
 

·
Registered
Joined
·
164 Posts
hey this happened on my dads ridgeline dealer pulled the main fuse and disconnected the battery and put it back together and then punched in the navi code
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
hey this happened on my dads ridgeline dealer pulled the main fuse and disconnected the battery and put it back together and then punched in the navi code
He never had any issues going forward with his Ridgeline? I'm going to attempt this myself.
 

·
Moderator
Joined
·
4,637 Posts
I remember Dreamacre has this issue with his 09 navi coupe. Send him a pm or search for his thread. I can't post links at the moment. Use the drop down menu, all threads started by Dreamacre for the thread.
 
1 - 5 of 5 Posts
Top