Drive Accord Honda Forums banner
1 - 9 of 9 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
i took out my battery terminals from 2019 accord sport 1.5.
after that i can't start my car , also red light is blinking in the console.
and showing initializing, please drive.
how i fix this, please help.
thanks
 

· Registered
Joined
·
366 Posts
Do exactly what it says. It lost the connection to the power system. All the sensors need to recalibrate themselves. I've done this a few times modding my car, just drive it'll be fine.

ALSO IF YOU HAVE A WHOLE BUNCH OF SYSTEM FAILURES BUT THE CAR STILL DRIVES FINE, it's because the terminals are loose and one clicked or something. I had that happen before.
 

· Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Do exactly what it says. It lost the connection to the power system. All the sensors need to recalibrate themselves. I've done this a few times modding my car, just drive it'll be fine.

ALSO IF YOU HAVE A WHOLE BUNCH OF SYSTEM FAILURES BUT THE CAR STILL DRIVES FINE, it's because the terminals are loose and one clicked or something. I had that happen before.
it keeps saying depress the break and start, when we do that i won't start,.then it'll show to push ignition button. it's keep repeating. is that we have to do? again and again?
 

· Registered
2020 Accord EX-L 1.5T
Joined
·
104 Posts
i took out my battery terminals from 2019 accord sport 1.5.
after that i can't start my car , also red light is blinking in the console.
and showing initializing, please drive.
how i fix this, please help.
If you are still within the Honda three year road side assistance time period, you might consider calling the Honda road-side assistance phone number on the driver door window. They may be able to help. I see you are in Canada, I am not sure how the roadside service works up there, so apologies if that is not an option for you.
 

· 3rd Car, 3rd Accord
Joined
·
112 Posts
I tried everything from turning the key in the door to taking the battery terminals off and touching them for 10 minutes. Nothing seems to work!! The factory immobilizer will not go off
I had this problem. Starter would crank and crank, no start. Vehicle was towed to a dealership. "bcm lost immobilizer f-can signal. Needs to be re-program bcm." Received the vehicle back operational with $130 bill for labour, i differed to warranty, they said Honda Canada Warranty declined the claim because "the customer removed the battery causing the issue" So public service, don't be honest or an intellectual, i recommend sloth.
 
1 - 9 of 9 Posts
Top