Drive Accord Honda Forums banner
1 - 4 of 4 Posts

·
2007 Accord EX-L 4D 5MT
Joined
·
200 Posts
Discussion Starter · #1 ·
I was looking up my P1259 and the search returned a lot of "check oil" and "clean solenoid" responses. My oil is fine, so I started looking for how to clean. Didn't really find anything so I went to youtube. I found this excellent troubleshooting video, which tells you more than you ever wanted to know about the VTEC pressure switch and solenoid. I'm posting it here in case anyone else is looking for P1259 troubleshooting.

http://www.youtube.com/watch?v=vTis29MQC4U
 

·
2007 Accord EX-L 4D 5MT
Joined
·
200 Posts
Discussion Starter · #2 ·
I got a chance to check out the solenoid yesterday afternoon. It had a lot of oil in the solenoid (green) plug so I cleaned it out as well as I could. After disconnecting the battery I used CRC QD Electronic cleaner spray to clean it out and then compressed air to blow out/dry both sides of the connector.

I did not remove it from the engine because of how hard the bolts are to reach. I think I got it pretty clean, but if the code comes back I'll take it off the car and clean it again on the bench before trying a new part. I've got to go to the pick-it yard anyway so I will try to pick up a spare if they have one.

I did take some photos, will try to post tonight.
 

·
2007 Accord EX-L 4D 5MT
Joined
·
200 Posts
Discussion Starter · #3 ·
I don't drive the car every day but drove it tonight and the P1259 has not returned yet. I hammered it pretty well to make it get into VTEC range at least 10 times, no code yet. Seems my cleaning took care of it, at least for now.

Here are some photos...
 

Attachments

·
2007 Accord EX-L 4D 5MT
Joined
·
200 Posts
Discussion Starter · #4 ·
Update: the code came back this weekend. Guess I'm going to have to get another solenoid.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top