Drive Accord Honda Forums banner
1 - 4 of 4 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi everyone, this is my first time posting, and hope I can get some help.
I have a 1998 Honda accord LX 4cyl, automatic with 67000 miles.
I had my suspension fixed a few days ago which included shocks, shock mounts and sway bar bushings because the car was not handling bumps well. A day after I took the car home, I am hearing a strange ticking/popping noise from the front passenger side when I am braking at speeds less then 15 - 20 mph. (Ex - If I hard brake, there is no noise). I took it back to the place I had the repair, but I think they're going to try and tell me its unrelated to their repairs and it has something to do with the brakes. I really don't think this is the case though. Can someone shed some light on the problem for me? Thank you so much

-Sanjay
 

· Banned
Joined
·
3,170 Posts
Hi everyone, this is my first time posting, and hope I can get some help.
I have a 1998 Honda accord LX 4cyl, automatic with 67000 miles.
I had my suspension fixed a few days ago which included shocks, shock mounts and sway bar bushings because the car was not handling bumps well. A day after I took the car home, I am hearing a strange ticking/popping noise from the front passenger side when I am braking at speeds less then 15 - 20 mph. (Ex - If I hard brake, there is no noise). I took it back to the place I had the repair, but I think they're going to try and tell me its unrelated to their repairs and it has something to do with the brakes. I really don't think this is the case though. Can someone shed some light on the problem for me? Thank you so much -Sanjay
Something repaired/replaced is obviously LOOSE. Else improperly installed. Return your car to the shop that did the work for a thorough inspection...and correction.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top