Drive Accord Honda Forums banner

1 - 17 of 17 Posts

·
K24 Power
Joined
·
123 Posts
Discussion Starter #1
Hey everybody I just installed a ported and polished 04 tsx manifold and hondata intake manifold gasket on my 05 accord 4 cyl sedan and I came across some problems. One is that my car doesn't idle correctly and also my car dies out. I checked all the hoses and reset the ecu and i still have the problem. Is the engine getting too much air? I have no check engine light either. Do I need to get my ECU chipped? I have headers, intake and 2 1/2 piping with exhaust. I just can't seem to find out what the problem is. Any help will be greatly appreciated. Thanks in advance.
 

·
Registered
Joined
·
17 Posts
Hey Wicked, I had some problems with my install too. Don't know if you have seen that thread, but for me it was the throttle plate that was not closing completely.

Fortunately it was easy to remedy by just adjusting the cable length with the lock nuts. Finding the right position was pretty easy for me since I could watch the movement of the plate while pressing the gas pedal sort of standing half way out of the car. I do have fairly long legs though, so I am sure that helped!

I think this could possibly he causing your idle issue, as far as it dying out, that sounds like a vacuum issue.

I know you said you checked the hoses, did you remember the small one on the bottom and back side of the manifold? Did you swap the TB studs from your accord IM? Did you check all the secondary connections? I had one pull loose, not where it attached to the manifold, but at the other end. I would also inspect your hoses carefully; one could have split during installation/removal.
 

·
Registered
Joined
·
269 Posts
I'd put money down that you have an install problem somewhere. This issue likely has nothing to do with the manifold itself.
 

·
K24 Power
Joined
·
123 Posts
Discussion Starter #4
Thanks for you help turbo. I'll check out the throttle plate and adjust the lock nuts on the cable. I did not swap out the studs but will do so today. Thanks for you help, hopefully this will solve my problem.

Hey Wicked, I had some problems with my install too. Don't know if you have seen that thread, but for me it was the throttle plate that was not closing completely.

Fortunately it was easy to remedy by just adjusting the cable length with the lock nuts. Finding the right position was pretty easy for me since I could watch the movement of the plate while pressing the gas pedal sort of standing half way out of the car. I do have fairly long legs though, so I am sure that helped!

I think this could possibly he causing your idle issue, as far as it dying out, that sounds like a vacuum issue.

I know you said you checked the hoses, did you remember the small one on the bottom and back side of the manifold? Did you swap the TB studs from your accord IM? Did you check all the secondary connections? I had one pull loose, not where it attached to the manifold, but at the other end. I would also inspect your hoses carefully; one could have split during installation/removal.
 

·
Registered
Joined
·
17 Posts
I did not swap out the studs but will do so today.
At first I really didn’t see the point in this until I threaded the nuts down. Then I noticed that they will bottom out on the TSX stud (run out of threads) before they contact the TB. It was late when I was working on mine and in a rush to finish I stacked a few washers on the stud to make up the difference in height. Ghetto, but it works, will get around to swapping the studs this weekend when I have more time. If those two nuts are not secured properly, it could certainly be a source of a vacuum leak. Good luck, hope it’s a quick and easy fix! :thmsup:
 

·
Legitimate hack
Joined
·
1,673 Posts
That's funny but I didn't experience that problem. IIRC, the throttle bodies are the same between the two as are the injector bases. I could be wrong though.
 

·
K24 Power
Joined
·
123 Posts
Discussion Starter #7
Quick question, is the tsx throttle body and accord tsx throttle body identical? I found the problem to be that the accord throttle body doesn't line up with the tsx manifold. Will the accord throttle body sensor work on the tsx throttle body? Any help will be greatly appreciated. =D
 

·
Legitimate hack
Joined
·
1,673 Posts
Sounds like you may have the wrong TSX manifold for your year. That's the only way I know for there to be any problems. Post a pic of your manifold and I'll be able to tell you for sure.

Also, do a little reading here: Click me!

Plenty of info there. Also, feel free to register and ask questions.
 

·
Registered
Joined
·
195 Posts
Quick question, is the tsx throttle body and accord tsx throttle body identical? I found the problem to be that the accord throttle body doesn't line up with the tsx manifold. Will the accord throttle body sensor work on the tsx throttle body? Any help will be greatly appreciated. =D
You've got the wrong manifold. It should line up perfectly
 

·
Registered
Joined
·
269 Posts
I'd put money down that you have an install problem somewhere. This issue likely has nothing to do with the manifold itself.
Yeah.............or you have the manifold for a drive-by-wire TSX.

The hole for the throttle blade, is it round or does it have a notched out part on one side of the circle? Does the throttle body gasket match up correctly?
 

·
K24 Power
Joined
·
123 Posts
Discussion Starter #11
Yeah.............or you have the manifold for a drive-by-wire TSX.

The hole for the throttle blade, is it round or does it have a notched out part on one side of the circle? Does the throttle body gasket match up correctly?
My stock accord tb has a notched out part one side of the circle. The manifold is from a 04 tsx and is completely round without the notch. If i get the tsx tb will it work ok on my car?
 

·
Legitimate hack
Joined
·
1,673 Posts
Won't make a difference. The TSX and Accord TB's are the same. I still think you have the wrong manifold. What are the letters on the manifold itself? Should start with an R. Also, where are the pics?
 

·
Registered
Joined
·
2,860 Posts
Won't make a difference. The TSX and Accord TB's are the same. I still think you have the wrong manifold. What are the letters on the manifold itself? Should start with an R. Also, where are the pics?
ITs the same for your year. Its different for the 06 tsx its 2mm larger and they got rid of the sqaure idle air cut out
 

·
Registered
Joined
·
3,126 Posts
They are not the same AFAIK . the 04 TSX TB is DBW (no idle speed valve) the 05 Honda has cutout for its cable operated TB that uses a idle speed controller valve .
That is his problem, no cutout for idle speed controller on the TSX IM.
 

·
Registered
Joined
·
195 Posts
They are not the same AFAIK . the 04 TSX TB is DBW (no idle speed valve) the 05 Honda has cutout for its cable operated TB that uses a idle speed controller valve .
That is his problem, no cutout for idle speed controller on the TSX IM.
^This is incorrect
I have an 04 tsx manifold on my 03 accord. all tsx's have been dbw since day one. all 2003-2005 accords are regular cable throttle. This has no bearing on the intake manifold itself at all.

OP you almost definately have an IM from the 2nd gen TSX as crackerteg said.
 

·
Registered
Joined
·
3,126 Posts
^This is incorrect
I have an 04 tsx manifold on my 03 accord. all tsx's have been dbw since day one. all 2003-2005 accords are regular cable throttle. This has no bearing on the intake manifold itself at all.

OP you almost definately have an IM from the 2nd gen TSX as crackerteg said.
So let me understand right . The TSX has DBW with a round IM TB inlet, (no cut out for idle speed) and the honda TB has cable and honda IM has a cutout for idle speed valve , if it was newer honda it have DBW too .

I think he having a low idle problem because it is getting blocked by the round opening in the TSX manifold . If there is no cutout I can't see how the air would bypass throttle to control idle speed and fast idle .
Thats how I see it, maybe I am wrong but please explain if so .

This kind of explains what I am talking about .

http://www.k20a.org/forum/showthread.php?t=78751

Edit : look here 2004 in this pic has a cutout so idle speed control will work on with cable TB . He claims his 04 TSX is round , I guess like Gen8 accord IM .

http://www.acurapartswarehouse.com/engine/e__01-2004-acura-tsx-4dr-tsx-ka5at-throttle-body-1.html
So it seems if that parts pic is right he has wrong one .

All I was saying is you need cutout for Idle speed valve to work .
 
1 - 17 of 17 Posts
Top