Drive Accord Honda Forums banner
1 - 5 of 5 Posts

· Registered
Joined
·
3,357 Posts
Either the retaining clip is damaged or missing due to repairs required removal of the sensor and person who worked on it damaged the connector or it is not being clipped properly due to debree inside preventing full engagement of the two halves mating together and causing the locking retaining clip not to engage or it is truly broken.
 

· Registered
Joined
·
3,357 Posts
Thanks for the reply, slides apart with no effort or resistance from contacts. No debris on sensor end. Hand pressing two halves together does not increase engagement; engagement apart by less than .5 inch. If clip is broken, contacts should still engage. I found problem with two halves together so it was not free much time for contamination to enter. Even thought it might be upside down but not so. I think they installed incorrect sensor
Then go back to the place that did the work and bring it up to their attention.
 

· Registered
Joined
·
3,357 Posts
Short term: increased fuel consumption.
Long term: catalytic converter 0lus plethora of other possible issues , of course oxygen sensors.
Going back to the shop to have issues corrected under warranty on work and parts should not be a thing to question.
 

· Registered
Joined
·
3,357 Posts
Buy genuine sensors, avoid at all costs eBay and Amazon generic sensors and even those for sale as a good brand name maybe counterfeits on those online shops. Find out what brand of the sensor was the OEM for your vehicle. Denso or NTK. I only used Denso brand sensors for all my vehicles.
 
1 - 5 of 5 Posts
Top